1 ################################################################################
5 ################################################################################
7 LIBEVENT_VERSION_MAJOR
= 2.0
8 LIBEVENT_VERSION
= $(LIBEVENT_VERSION_MAJOR
).22-stable
9 LIBEVENT_SITE
= http
://downloads.sourceforge.net
/project
/levent
/libevent
/libevent-
$(LIBEVENT_VERSION_MAJOR
)
10 LIBEVENT_INSTALL_STAGING
= YES
11 LIBEVENT_LICENSE
= BSD-3c
, OpenBSD
12 LIBEVENT_LICENSE_FILES
= LICENSE
13 # For 0001-Disable-building-test-programs.patch
14 LIBEVENT_AUTORECONF
= YES
16 define LIBEVENT_REMOVE_PYSCRIPT
17 rm $(TARGET_DIR
)/usr
/bin
/event_rpcgen.py
20 # libevent installs a python script to target - get rid of it if we
21 # don't have python support enabled
22 ifneq ($(BR2_PACKAGE_PYTHON
),y
)
23 LIBEVENT_POST_INSTALL_TARGET_HOOKS
+= LIBEVENT_REMOVE_PYSCRIPT
26 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
27 LIBEVENT_DEPENDENCIES
+= openssl
28 LIBEVENT_CONF_OPTS
+= --enable-openssl
29 # openssl needs zlib but configure forgets to link against it causing
30 # openssl detection to fail
31 ifeq ($(BR2_STATIC_LIBS
),y
)
32 LIBEVENT_CONF_ENV
+= OPENSSL_LIBADD
='-lz'
35 LIBEVENT_CONF_OPTS
+= --disable-openssl
38 $(eval
$(autotools-package
))
39 $(eval
$(host-autotools-package
))