package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / omniorb / omniorb.mk
blobaaf3bf32228e0191643c108460618571fb8c1fdf
1 ################################################################################
3 # omniorb
5 ################################################################################
7 OMNIORB_VERSION = 4.2.0
8 OMNIORB_SITE = http://downloads.sourceforge.net/project/omniorb/omniORB/omniORB-$(OMNIORB_VERSION)
9 OMNIORB_SOURCE = omniORB-$(OMNIORB_VERSION).tar.bz2
10 OMNIORB_INSTALL_STAGING = YES
11 OMNIORB_LICENSE = GPL2+, LGPLv2.1+
12 OMNIORB_LICENSE_FILES = COPYING COPYING.LIB
13 OMNIORB_DEPENDENCIES = host-omniorb
14 HOST_OMNIORB_DEPENDENCIES = host-python
16 # 0001-uclinux-is-also-linux.patch touches configure.ac
17 OMNIORB_AUTORECONF = YES
19 # omniorb is not python3 friendly, so force the python interpreter
20 OMNIORB_CONF_OPTS = ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
21 HOST_OMNIORB_CONF_OPTS = ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python2
23 # Defaulting long double support to a safe option for the
24 # mix of embedded targets, this could later be automated
25 # based on checking the capability of the cross toolchain
26 # for "__LONG_DOUBLE_128__". Currently the host and target
27 # need to match because of the code generation done by the
28 # host tools during the target compile (ie headers generated
29 # on host are used in target build).
30 OMNIORB_CONF_OPTS += --disable-longdouble
31 HOST_OMNIORB_CONF_OPTS += --disable-longdouble
33 # The EmbeddedSystem define (set below in OMNIORB_ADJUST_TOOLDIR)
34 # enables building of just the lib and disables building of
35 # tools/apps/services. In some cases the apps/services are still
36 # required. The tools however are host related and should never
37 # be required on target.
38 define OMNIORB_ENABLE_EXTRA_APPS
39 $(SED) 's:SUBDIRS += lib:SUBDIRS += lib appl services:g' $(@D)/src/dir.mk
40 endef
42 ifeq ($(BR2_PACKAGE_OMNIORB_WITH_APPS),y)
43 OMNIORB_POST_PATCH_HOOKS += OMNIORB_ENABLE_EXTRA_APPS
44 endif
46 ifeq ($(BR2_STATIC_LIBS),y)
47 define OMNIORB_DISABLE_SHARED
48 echo "BuildSharedLibrary =" >> $(@D)/mk/beforeauto.mk
49 endef
50 OMNIORB_POST_CONFIGURE_HOOKS += OMNIORB_DISABLE_SHARED
51 endif
53 # omniORB is not completely cross-compile friendly and has some
54 # assumptions where a couple host tools must be built and then
55 # used by the target build. The host tools generate code from
56 # the IDL description language, which is then built into the
57 # cross compiled target OMNIORB application.
58 define OMNIORB_ADJUST_TOOLDIR
59 # Point to the host folder to get HOST_OMNIORB tools
60 $(SED) 's:TOOLBINDIR = $$(TOP)/$$(BINDIR):TOOLBINDIR = $(HOST_DIR)/usr/bin:g' $(@D)/mk/beforeauto.mk
61 # Disables OMNIORB app/service/tool building
62 echo "EmbeddedSystem=1" >> $(@D)/mk/beforeauto.mk
63 endef
64 OMNIORB_POST_CONFIGURE_HOOKS += OMNIORB_ADJUST_TOOLDIR
66 $(eval $(autotools-package))
67 $(eval $(host-autotools-package))