package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / php-memcached / php-memcached.mk
blob599e22e615f97c2f91154752b017559947935567
1 ################################################################################
3 # php-memcached
5 ################################################################################
7 PHP_MEMCACHED_VERSION = 2.2.0
8 PHP_MEMCACHED_SOURCE = memcached-$(PHP_MEMCACHED_VERSION).tgz
9 # pecl.php.net returns html with db connect failed
10 PHP_MEMCACHED_SITE = http://sources.buildroot.net
11 PHP_MEMCACHED_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
12 --disable-memcached-sasl \
13 --with-libmemcached-dir=$(STAGING_DIR)/usr \
14 --with-zlib-dir=$(STAGING_DIR)/usr
15 # phpize does the autoconf magic
16 PHP_MEMCACHED_DEPENDENCIES = libmemcached php zlib host-autoconf host-pkgconf
17 PHP_MEMCACHED_LICENSE = MIT
18 PHP_MEMCACHED_LICENSE_FILES = LICENSE
20 define PHP_MEMCACHED_PHPIZE
21 (cd $(@D); \
22 PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
23 PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
24 $(STAGING_DIR)/usr/bin/phpize)
25 endef
27 PHP_MEMCACHED_PRE_CONFIGURE_HOOKS += PHP_MEMCACHED_PHPIZE
29 $(eval $(autotools-package))