package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / setools / setools.mk
blobdeb421fe6555ce7f3fd47f31d01a51c1b9bce7f7
1 ################################################################################
3 # setools
5 ################################################################################
7 SETOOLS_VERSION = 3.3.8
8 SETOOLS_SOURCE = setools-$(SETOOLS_VERSION).tar.bz2
9 SETOOLS_SITE = https://raw.githubusercontent.com/wiki/TresysTechnology/setools3/files/dists/setools-$(SETOOLS_VERSION)
10 SETOOLS_DEPENDENCIES = libselinux libsepol sqlite libxml2 bzip2 host-bison host-flex
11 SETOOLS_INSTALL_STAGING = YES
12 SETOOLS_LICENSE = GPLv2+, LGPLv2.1+
13 SETOOLS_LICENSE_FILES = COPYING COPYING.GPL COPYING.LGPL
15 # configure.ac is patched by the cross compile patch,
16 # so autoreconf is necessary
17 SETOOLS_AUTORECONF = YES
19 # Notes: Need "disable-selinux-check" so the configure does not check to see
20 # if host has selinux enabled.
21 # No python support as only the libraries and commandline tools are
22 # installed on target
23 SETOOLS_CONF_OPTS = \
24 --disable-debug \
25 --disable-gui \
26 --disable-bwidget-check \
27 --disable-selinux-check \
28 --disable-swig-java \
29 --disable-swig-python \
30 --disable-swig-tcl \
31 --with-sepol-devel="$(STAGING_DIR)/usr" \
32 --with-selinux-devel="$(STAGING_DIR)/usr"
34 HOST_SETOOLS_DEPENDENCIES = host-libselinux host-libsepol host-sqlite \
35 host-libxml2 host-bzip2 host-bison
37 ifeq ($(BR2_PACKAGE_PYTHON3),y)
38 HOST_SETOOLS_PYTHON_VERSION=$(PYTHON3_VERSION_MAJOR)
39 HOST_SETOOLS_DEPENDENCIES += host-python3
40 HOST_SETOOLS_CONF_ENV += am_cv_python_version=$(PYTHON3_VERSION)
41 else
42 HOST_SETOOLS_PYTHON_VERSION=$(PYTHON_VERSION_MAJOR)
43 HOST_SETOOLS_DEPENDENCIES += host-python
44 HOST_SETOOLS_CONF_ENV += am_cv_python_version=$(PYTHON_VERSION)
45 endif
47 HOST_SETOOLS_PYTHON_SITE_PACKAGES = $(HOST_DIR)/usr/lib/python$(HOST_SETOOLS_PYTHON_VERSION)/site-packages
48 HOST_SETOOLS_PYTHON_INCLUDES = $(HOST_DIR)/usr/include/python$(HOST_SETOOLS_PYTHON_VERSION)
49 HOST_SETOOLS_PYTHON_LIB = -lpython$(HOST_SETOOLS_PYTHON_VERSION)
51 # Notes: Need "disable-selinux-check" so the configure does not check to see
52 # if host has selinux enabled.
53 # Host builds with python support to enable tools for offline target
54 # policy analysis
55 HOST_SETOOLS_CONF_OPTS = \
56 --disable-debug \
57 --disable-gui \
58 --disable-bwidget-check \
59 --disable-selinux-check \
60 --disable-swig-java \
61 --disable-swig-python \
62 --disable-swig-tcl \
63 --with-sepol-devel="$(HOST_DIR)/usr" \
64 --with-selinux-devel="$(HOST_DIR)/usr" \
65 PYTHON_LDFLAGS="-L$(HOST_DIR)/usr/lib/" \
66 PYTHON_CPPFLAGS="-I$(HOST_SETOOLS_PYTHON_INCLUDES)" \
67 PYTHON_SITE_PKG="$(HOST_SETOOLS_PYTHON_SITE_PACKAGES)" \
68 PYTHON_EXTRA_LIBS="-lpthread -ldl -lutil $(HOST_SETOOLS_PYTHON_LIB)"
70 HOST_SETOOLS_CONF_ENV += \
71 am_cv_pathless_PYTHON=python \
72 ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python \
73 am_cv_python_platform=linux2 \
74 am_cv_python_version=$(HOST_SETOOLS_PYTHON_VERSION) \
75 am_cv_python_pythondir=$(HOST_SETOOLS_PYTHON_SITE_PACKAGES) \
76 am_cv_python_pyexecdir=$(HOST_SETOOLS_PYTHON_SITE_PACKAGES) \
77 am_cv_python_includes=-I$(HOST_SETOOLS_PYTHON_INCLUDES)
79 $(eval $(autotools-package))
80 $(eval $(host-autotools-package))