1 ################################################################################
5 ################################################################################
8 ZEROMQ_SITE
= http
://download.zeromq.org
9 ZEROMQ_INSTALL_STAGING
= YES
10 ZEROMQ_DEPENDENCIES
= util-linux
11 ZEROMQ_LICENSE
= LGPLv3
+ with exceptions
12 ZEROMQ_LICENSE_FILES
= COPYING COPYING.LESSER
13 # For 0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch
14 ZEROMQ_AUTORECONF
= YES
16 # Assume these flags are always available. It is true, at least for
17 # SOCK_CLOEXEC, since linux v2.6.27.
18 # Note: the flag TCP_KEEPALIVE is NOT available so we do not include it.
19 ZEROMQ_CONF_ENV
= libzmq_cv_sock_cloexec
=yes \
20 libzmq_cv_so_keepalive
=yes \
21 libzmq_cv_tcp_keepcnt
=yes \
22 libzmq_cv_tcp_keepidle
=yes \
23 libzmq_cv_tcp_keepintvl
=yes
25 # Only tools/curve_keygen.c needs this, but it doesn't hurt to pass it
26 # for the rest of the build as well (which automatically includes stdc++).
27 ifeq ($(BR2_STATIC_LIBS
),y
)
28 ZEROMQ_CONF_OPTS
+= LIBS
=-lstdc
++
31 ifeq ($(BR2_PACKAGE_ZEROMQ_PGM
),y
)
32 ZEROMQ_DEPENDENCIES
+= host-pkgconf openpgm
33 ZEROMQ_CONF_OPTS
+= --with-system-pgm
36 # ZeroMQ uses libsodium if it's available.
37 ifeq ($(BR2_PACKAGE_LIBSODIUM
),y
)
38 ZEROMQ_DEPENDENCIES
+= libsodium
39 ZEROMQ_CONF_OPTS
+= --with-libsodium
="$(STAGING_DIR)/usr"
41 ZEROMQ_CONF_OPTS
+= --without-libsodium
44 $(eval
$(autotools-package
))