imagemagick: bump version to 7.0.3-7 (security)
[buildroot-gz.git] / package / libldns / libldns.mk
blob3d4d35688c7fbef48b0c760fe1452fd143d4df02
1 ################################################################################
3 # libldns
5 ################################################################################
7 LIBLDNS_VERSION = 1.6.17
8 LIBLDNS_SOURCE = ldns-$(LIBLDNS_VERSION).tar.gz
9 LIBLDNS_SITE = http://www.nlnetlabs.nl/downloads/ldns
10 LIBLDNS_LICENSE = BSD-3c
11 LIBLDNS_LICENSE_FILES = LICENSE
12 LIBLDNS_INSTALL_STAGING = YES
13 LIBLDNS_CONF_OPTS = \
14 --without-examples \
15 --without-p5-dns-ldns \
16 --without-pyldns \
17 --without-pyldnsx
19 ifeq ($(BR2_PACKAGE_OPENSSL),y)
20 LIBLDNS_DEPENDENCIES += openssl
21 LIBLDNS_CONF_OPTS += \
22 --with-ssl=$(STAGING_DIR)/usr \
23 --enable-dane \
24 --enable-ecdsa \
25 --enable-gost \
26 --enable-sha2
28 ifeq ($(BR2_STATIC_LIBS),y)
29 LIBLDNS_DEPENDENCIES += host-pkgconf
30 # missing -lz breaks configure, add it using pkgconf
31 LIBLDNS_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs openssl`"
32 endif
34 else
35 LIBLDNS_CONF_OPTS += \
36 --without-ssl \
37 --disable-dane \
38 --disable-ecdsa \
39 --disable-gost \
40 --disable-sha2
41 endif
43 # the linktest make target fails with static linking, and we are only
44 # interested in the lib target anyway
45 LIBLDNS_MAKE_OPTS = lib
47 $(eval $(autotools-package))