1 ################################################################################
5 ################################################################################
7 LTRACE_VERSION
= c22d359433b333937ee3d803450dc41998115685
8 LTRACE_SITE
= git
://anonscm.debian.org
/collab-maint
/ltrace.git
9 LTRACE_DEPENDENCIES
= elfutils
10 LTRACE_CONF_OPTS
= --disable-werror
11 LTRACE_LICENSE
= GPLv2
12 LTRACE_LICENSE_FILES
= COPYING
13 LTRACE_AUTORECONF
= YES
15 define LTRACE_CREATE_CONFIG_M4
16 mkdir
-p
$(@D
)/config
/m4
18 LTRACE_POST_PATCH_HOOKS
+= LTRACE_CREATE_CONFIG_M4
20 # ltrace can use libunwind only if libc has backtrace() support
21 # We don't normally do so for uClibc and we can't know if it's external
22 # Also ltrace with libunwind support is broken for MIPS so we disable it
23 ifeq ($(BR2_PACKAGE_LIBUNWIND
),y
)
24 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC
)$(BR2_mips
)$(BR2_mipsel
),)
25 # --with-elfutils only selects unwinding support backend. elfutils is a
26 # mandatory dependency regardless.
27 LTRACE_CONF_OPTS
+= --with-libunwind
=yes
--with-elfutils
=no
28 LTRACE_DEPENDENCIES
+= libunwind
30 LTRACE_CONF_OPTS
+= --with-libunwind
=no
34 $(eval
$(autotools-package
))