imagemagick: bump version to 7.0.3-7 (security)
[buildroot-gz.git] / package / owfs / owfs.mk
blobe0679d21b72da78e51fa5af5542908ea079bcc4e
1 ################################################################################
3 # owfs
5 ################################################################################
7 OWFS_VERSION = 3.1p1
8 OWFS_SITE = http://downloads.sourceforge.net/project/owfs/owfs/$(OWFS_VERSION)
9 OWFS_DEPENDENCIES = host-pkgconf
10 OWFS_CONF_OPTS = --disable-owperl --without-perl5 --disable-owtcl --without-tcl
12 # 0001-configure.ac-check-for-localtime_r.patch touches configure.ac
13 OWFS_AUTORECONF = YES
15 # owtcl license is declared in module/ownet/c/src/include/ow_functions.h
16 OWFS_LICENSE = GPLv2+, LGPLv2 (owtcl)
17 OWFS_LICENSE_FILES = COPYING COPYING.LIB
18 OWFS_INSTALL_STAGING = YES
20 # owfs PHP support is not PHP 7 compliant
21 # https://sourceforge.net/p/owfs/support-requests/32/
22 OWFS_CONF_OPTS += --disable-owphp --without-php
24 ifeq ($(BR2_PACKAGE_LIBFUSE),y)
25 OWFS_DEPENDENCIES += libfuse
26 OWFS_CONF_OPTS += \
27 --enable-owfs \
28 --with-fuseinclude=$(STAGING_DIR)/usr/include \
29 --with-fuselib=$(STAGING_DIR)/usr/lib
30 define OWFS_INSTALL_FUSE_INIT_SYSV
31 $(INSTALL) -D -m 0755 $(OWFS_PKGDIR)S30owfs \
32 $(TARGET_DIR)/etc/init.d/S30owfs
33 endef
34 define OWFS_CREATE_MOUNTPOINT
35 mkdir -p $(TARGET_DIR)/dev/1wire
36 endef
37 OWFS_POST_INSTALL_TARGET_HOOKS += OWFS_CREATE_MOUNTPOINT
38 else
39 OWFS_CONF_OPTS += --disable-owfs
40 endif
42 ifeq ($(BR2_PACKAGE_LIBUSB),y)
43 OWFS_CONF_OPTS += --enable-usb
44 OWFS_DEPENDENCIES += libusb
45 else
46 OWFS_CONF_OPTS += --disable-usb
47 endif
49 ifeq ($(BR2_PACKAGE_AVAHI),y)
50 OWFS_CONF_OPTS += --enable-avahi
51 OWFS_DEPENDENCIES += avahi
52 else
53 OWFS_CONF_OPTS += --disable-avahi
54 endif
56 # setup.py isn't python3 compliant
57 ifeq ($(BR2_PACKAGE_PYTHON),y)
58 OWFS_CONF_OPTS += \
59 --enable-owpython \
60 --with-python \
61 --with-pythonconfig=$(STAGING_DIR)/usr/bin/python-config
62 OWFS_MAKE_ENV += \
63 CC="$(TARGET_CC)" \
64 PYTHONPATH="$(PYTHON_PATH)" \
65 _python_sysroot=$(STAGING_DIR) \
66 _python_prefix=/usr \
67 _python_exec_prefix=/usr
68 OWFS_DEPENDENCIES += python host-swig
69 # The configure scripts finds PYSITEDIR as the python_lib directory of
70 # host-python, and then prepends DESTDIR in front of it. So we end up
71 # installing things in $(TARGET_DIR)/$(HOST_DIR)/usr/lib/python which is
72 # clearly wrong.
73 # Patching owfs to do the right thing is not trivial, it's much easier to
74 # override the PYSITEDIR variable in make.
75 OWFS_EXTRA_MAKE_OPTS += PYSITEDIR=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
76 else
77 OWFS_CONF_OPTS += --disable-owpython --without-python
78 endif
80 ifeq ($(BR2_STATIC_LIBS),y)
81 # zeroconf support uses dlopen()
82 OWFS_CONF_OPTS += --disable-zero
83 endif
85 OWFS_MAKE = $(MAKE) $(OWFS_EXTRA_MAKE_OPTS)
87 define OWFS_INSTALL_INIT_SYSV
88 $(INSTALL) -D -m 0755 $(OWFS_PKGDIR)S25owserver \
89 $(TARGET_DIR)/etc/init.d/S25owserver
90 $(OWFS_INSTALL_FUSE_INIT_SYSV)
91 endef
93 $(eval $(autotools-package))