1 ################################################################################
5 ################################################################################
7 BANDWIDTHD_VERSION
= v2.0
.1-auto-r11
8 BANDWIDTHD_SITE
= $(call github
,nroach44
,bandwidthd
,$(BANDWIDTHD_VERSION
))
10 # Specified as "any version of the GPL that is current as of your
11 # download" by upstream.
12 BANDWIDTHD_LICENSE
= GPL
14 BANDWIDTHD_DEPENDENCIES
= gd libpng libpcap host-pkgconf
16 BANDWIDTHD_AUTORECONF
= YES
18 BANDWIDTHD_CONF_OPTS
+= --with-pcap-config
=$(STAGING_DIR
)/usr
/bin
/pcap-config
20 ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL
),y
)
21 BANDWIDTHD_DEPENDENCIES
+= postgresql
22 BANDWIDTHD_CONF_OPTS
+= --with-postgresql-logging
=true
24 BANDWIDTHD_CONF_OPTS
+= --with-postgresql-logging
=false
27 ifeq ($(BR2_PACKAGE_BANDWIDTHD_SQLITE3
),y
)
28 BANDWIDTHD_DEPENDENCIES
+= sqlite
29 BANDWIDTHD_CONF_OPTS
+= --with-sqlite-storage
=true
31 BANDWIDTHD_CONF_OPTS
+= --with-sqlite-storage
=false
34 define BANDWIDTHD_INSTALL_INIT_SYSTEMD
35 $(INSTALL
) -D
-m
644 package
/bandwidthd
/bandwidthd.service \
36 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/bandwidthd.service
38 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
40 ln
-sf
/usr
/lib
/systemd
/system
/bandwidthd.service \
41 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/bandwidthd.service
44 $(eval
$(autotools-package
))