janus-gateway: make echo test plugin optional
[buildroot-gz.git] / package / janus-gateway / janus-gateway.mk
blobce1239312957c98dbd0c6b916fefba135b0a5739
1 ################################################################################
3 # janus-gateway
5 ################################################################################
7 JANUS_GATEWAY_VERSION = v0.2.1
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPLv3
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14 libsrtp host-gengetopt libglib2 openssl
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
20 define JANUS_GATEWAY_M4
21 mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
25 JANUS_GATEWAY_CONF_OPTS = \
26 --disable-data-channels \
27 --disable-rabbitmq
29 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE),y)
30 JANUS_GATEWAY_DEPENDENCIES += opus
31 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
32 else
33 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
34 endif
36 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST),y)
37 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
38 else
39 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
40 endif
42 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
43 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
44 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
45 else
46 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
47 endif
49 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
50 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
51 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
52 else
53 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
54 endif
56 ifeq ($(BR2_PACKAGE_LIBOGG),y)
57 JANUS_GATEWAY_DEPENDENCIES += libogg
58 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
59 else
60 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
61 endif
63 # Parallel build broken
64 JANUS_GATEWAY_MAKE = $(MAKE1)
66 $(eval $(autotools-package))