janus-gateway: make echo test plugin optional
[buildroot-gz.git] / package / librtlsdr / librtlsdr.mk
blob51ecabe14a3d593a9e3cb58b713fdb31bd67d65a
1 ################################################################################
3 # librtlsdr
5 ################################################################################
7 LIBRTLSDR_VERSION = v0.5.3
8 LIBRTLSDR_SITE = $(call github,steve-m,librtlsdr,$(LIBRTLSDR_VERSION))
9 LIBRTLSDR_LICENSE = GPLv2+
10 LIBRTLSDR_LICENSE_FILES = COPYING
11 LIBRTLSDR_INSTALL_STAGING = YES
12 LIBRTLSDR_DEPENDENCIES = libusb
14 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
15 LIBRTLSDR_CONF_OPTS += -DINSTALL_UDEV_RULES=ON
16 endif
18 ifeq ($(BR2_PACKAGE_LIBRTLSDR_DETACH_DRIVER),y)
19 LIBRTLSDR_CONF_OPTS += -DDETACH_KERNEL_DRIVER=1
20 endif
22 # In case of static-lib-only builds, CMake's FindThreads.cmake code tries to
23 # get the right flags, checking first for -lpthreads, then -lpthread, and lastly
24 # for -pthread.
25 # The 2 first link checks fail because of undefined symbols: __libc_setup_tls.
26 # In the later check, CMake successfully compiles and links the test program,
27 # but it also tries to run it, which is wrong when cross-compiling.
29 # The following CMake variable only disables the TRY_RUN call in the -pthread
30 # test.
31 LIBRTLSDR_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
33 $(eval $(cmake-package))