1 ################################################################################
5 ################################################################################
7 OPENPGM_VERSION
= release-5-2-122
8 OPENPGM_SITE
= $(call github
,steve-o
,openpgm
,$(OPENPGM_VERSION
))
9 OPENPGM_LICENSE
= LGPLv2.1
+
10 OPENPGM_LICENSE_FILES
= openpgm
/pgm
/LICENSE
11 OPENPGM_INSTALL_STAGING
= YES
12 OPENPGM_SUBDIR
= openpgm
/pgm
13 OPENPGM_AUTORECONF
= YES
15 # We need to create the m4 directory to make sure that autoreconf will
16 # start calling libtoolize. Otherwise it will start with aclocal and it
17 # will fail because the m4 directory doesn't exist.
18 define OPENPGM_CREATE_M4_DIR
19 mkdir
-p
$(@D
)/$(OPENPGM_SUBDIR
)/m4
21 OPENPGM_POST_PATCH_HOOKS
+= OPENPGM_CREATE_M4_DIR
24 ac_cv_file__proc_cpuinfo
=yes \
25 ac_cv_file__dev_rtc
=no \
26 ac_cv_file__dev_hpet
=no
28 $(eval
$(autotools-package
))