janus-gateway: make echo test plugin optional
[buildroot-gz.git] / package / sdl_sound / sdl_sound.mk
blob4fa7d9be0a744b9d1883cc9f101540f600453802
1 ################################################################################
3 # sdl_sound
5 ################################################################################
7 SDL_SOUND_VERSION = 1.0.3
8 SDL_SOUND_SOURCE = SDL_sound-$(SDL_SOUND_VERSION).tar.gz
9 SDL_SOUND_SITE = http://icculus.org/SDL_sound/downloads
10 SDL_SOUND_LICENSE = LGPLv2.1+
11 SDL_SOUND_LICENSE_FILES = COPYING
12 SDL_SOUND_INSTALL_STAGING = YES
13 SDL_SOUND_DEPENDENCIES = sdl
15 ifneq ($(BR2_ENABLE_LOCALE),y)
16 SDL_SOUND_DEPENDENCIES += libiconv
17 endif
19 # optional dependencies
20 ifeq ($(BR2_PACKAGE_FLAC)$(BR2_PACKAGE_LIBOGG),yy)
21 SDL_SOUND_CONF_OPTS += --enable-flac
22 SDL_SOUND_DEPENDENCIES += flac libogg
23 else
24 SDL_SOUND_CONF_OPTS += --disable-flac
25 endif
27 ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
28 SDL_SOUND_CONF_OPTS += --enable-modplug
29 SDL_SOUND_DEPENDENCIES += libmodplug
30 else
31 SDL_SOUND_CONF_OPTS += --disable-modplug
32 endif
34 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
35 SDL_SOUND_CONF_OPTS += --enable-ogg
36 SDL_SOUND_DEPENDENCIES += libvorbis
37 else
38 SDL_SOUND_CONF_OPTS += --disable-ogg
39 endif
41 ifeq ($(BR2_PACKAGE_SPEEX),y)
42 SDL_SOUND_CONF_OPTS += --enable-speex
43 SDL_SOUND_DEPENDENCIES += speex
44 else
45 SDL_SOUND_CONF_OPTS += --disable-speex
46 endif
48 SDL_SOUND_CONF_OPTS = \
49 --with-sdl-prefix=$(STAGING_DIR)/usr \
50 --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
51 --disable-sdltest \
52 --enable-static
54 ifeq ($(BR2_X86_CPU_HAS_MMX),y)
55 SDL_SOUND_CONF_OPTS += --enable-mmx
56 else
57 SDL_SOUND_CONF_OPTS += --disable-mmx
58 endif
60 define SDL_SOUND_REMOVE_PLAYSOUND
61 rm $(addprefix $(TARGET_DIR)/usr/bin/,playsound playsound_simple)
62 endef
64 ifneq ($(BR2_PACKAGE_SDL_SOUND_PLAYSOUND),y)
65 SDL_SOUND_POST_INSTALL_TARGET_HOOKS += SDL_SOUND_REMOVE_PLAYSOUND
66 endif
68 $(eval $(autotools-package))