1 ################################################################################
5 ################################################################################
8 FFTW_SITE
= http
://www.fftw.org
9 FFTW_INSTALL_STAGING
= YES
11 FFTW_LICENSE_FILES
= COPYING
13 # fortran support only enables generation and installation of fortran sources
14 ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN
),y
)
15 FFTW_CONF_OPTS
+= --enable-fortran
16 FFTW_CONF_ENV
+= FLIBS
="-lgfortran -lm"
18 FFTW_CONF_OPTS
+= --disable-fortran
21 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_SINGLE
),--enable
,--disable
)-single
22 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE
),--enable
,--disable
)-long-double
23 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_PRECISION_QUAD
),--enable
,--disable
)-quad-precision
25 FFTW_CFLAGS
= $(TARGET_CFLAGS
)
26 ifeq ($(BR2_PACKAGE_FFTW_FAST
),y
)
27 FFTW_CFLAGS
+= -O3
-ffast-math
31 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_SSE
),--enable
,--disable
)-sse
32 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_SSE2
),--enable
,--disable
)-sse2
35 FFTW_CONF_OPTS
+= $(if
$(BR2_PACKAGE_FFTW_USE_NEON
),--enable
,--disable
)-neon
36 FFTW_CFLAGS
+= $(if
$(BR2_PACKAGE_FFTW_USE_NEON
),-mfpu
=neon
)
38 # Generic optimisations
39 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),y
)
40 FFTW_CONF_OPTS
+= --enable-threads
41 FFTW_CONF_OPTS
+= $(if
$(BR2_GCC_ENABLE_OPENMP
),--without
,--with
)-combined-threads
43 FFTW_CONF_OPTS
+= --disable-threads
45 FFTW_CONF_OPTS
+= $(if
$(BR2_GCC_ENABLE_OPENMP
),--enable
,--disable
)-openmp
47 FFTW_CONF_OPTS
+= CFLAGS
="$(FFTW_CFLAGS)"
49 $(eval
$(autotools-package
))