package/x11r7/xdriver_xf86-video-openchrome: bump version to 0.5.0
[buildroot-gz.git] / package / fftw / fftw.mk
blob5bd39a8ff2b47883d391f0f660fd8dec9f5761a1
1 ################################################################################
3 # fftw
5 ################################################################################
7 FFTW_VERSION = 3.3.4
8 FFTW_SITE = http://www.fftw.org
9 FFTW_INSTALL_STAGING = YES
10 FFTW_LICENSE = GPLv2+
11 FFTW_LICENSE_FILES = COPYING
13 # fortran support only enables generation and installation of fortran sources
14 ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),y)
15 FFTW_CONF_OPTS += --enable-fortran
16 FFTW_CONF_ENV += FLIBS="-lgfortran -lm"
17 else
18 FFTW_CONF_OPTS += --disable-fortran
19 endif
21 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_SINGLE),--enable,--disable)-single
22 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),--enable,--disable)-long-double
23 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_QUAD),--enable,--disable)-quad-precision
25 FFTW_CFLAGS = $(TARGET_CFLAGS)
26 ifeq ($(BR2_PACKAGE_FFTW_FAST),y)
27 FFTW_CFLAGS += -O3 -ffast-math
28 endif
30 # x86 optimisations
31 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_SSE),--enable,--disable)-sse
32 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_SSE2),--enable,--disable)-sse2
34 # ARM optimisations
35 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_USE_NEON),--enable,--disable)-neon
36 FFTW_CFLAGS += $(if $(BR2_PACKAGE_FFTW_USE_NEON),-mfpu=neon)
38 # Generic optimisations
39 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
40 FFTW_CONF_OPTS += --enable-threads
41 FFTW_CONF_OPTS += $(if $(BR2_GCC_ENABLE_OPENMP),--without,--with)-combined-threads
42 else
43 FFTW_CONF_OPTS += --disable-threads
44 endif
45 FFTW_CONF_OPTS += $(if $(BR2_GCC_ENABLE_OPENMP),--enable,--disable)-openmp
47 FFTW_CONF_OPTS += CFLAGS="$(FFTW_CFLAGS)"
49 $(eval $(autotools-package))