package/x11r7/xdriver_xf86-video-openchrome: bump version to 0.5.0
[buildroot-gz.git] / package / nmap / nmap.mk
blob3087903a929c0f529618da54ea6a78aeb2a07afa
1 ################################################################################
3 # nmap
5 ################################################################################
7 NMAP_VERSION = 7.31
8 NMAP_SITE = http://nmap.org/dist
9 NMAP_SOURCE = nmap-$(NMAP_VERSION).tar.bz2
10 NMAP_DEPENDENCIES = libpcap pcre
11 NMAP_CONF_OPTS = --without-liblua --without-zenmap \
12 --with-libdnet=included --with-liblinear=included \
13 --with-libpcre="$(STAGING_DIR)/usr" --without-ncat
14 NMAP_LICENSE = GPLv2
15 NMAP_LICENSE_FILES = COPYING
17 # needed by libpcap
18 NMAP_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
20 ifeq ($(BR2_STATIC_LIBS),y)
21 NMAP_CONF_ENV += LIBS="$(NMAP_LIBS_FOR_STATIC_LINK)"
22 endif
24 # for 0001-libdnet-wrapper-configure.patch
25 define NMAP_WRAPPER_EXEC
26 chmod +x $(@D)/libdnet-stripped/configure.gnu
27 endef
28 NMAP_POST_PATCH_HOOKS += NMAP_WRAPPER_EXEC
30 ifeq ($(BR2_PACKAGE_OPENSSL),y)
31 NMAP_CONF_OPTS += --with-openssl="$(STAGING_DIR)/usr"
32 NMAP_DEPENDENCIES += host-pkgconf openssl
33 NMAP_LIBS_FOR_STATIC_LINK += `$(PKG_CONFIG_HOST_BINARY) --libs openssl`
34 else
35 NMAP_CONF_OPTS += --without-openssl
36 endif
38 # ndiff only works with python2.x
39 ifeq ($(BR2_PACKAGE_PYTHON),y)
40 NMAP_DEPENDENCIES += python
41 else
42 NMAP_CONF_OPTS += --without-ndiff
43 endif
45 $(eval $(autotools-package))