package/x11r7/xdriver_xf86-video-openchrome: bump version to 0.5.0
[buildroot-gz.git] / package / omxplayer / omxplayer.mk
blobda4614bf56045b7c444d02673d701862d4053fa7
1 ################################################################################
3 # omxplayer
5 ################################################################################
7 OMXPLAYER_VERSION = 6c90c7503ba4658221774759edf7f2ae816711de
8 OMXPLAYER_SITE = $(call github,popcornmix,omxplayer,$(OMXPLAYER_VERSION))
9 OMXPLAYER_LICENSE = GPLv2+
10 OMXPLAYER_LICENSE_FILES = COPYING
12 OMXPLAYER_DEPENDENCIES = \
13 host-pkgconf boost dbus ffmpeg freetype libidn libusb pcre \
14 rpi-userland zlib
16 OMXPLAYER_EXTRA_CFLAGS = \
17 -DTARGET_LINUX -DTARGET_POSIX \
18 `$(PKG_CONFIG_HOST_BINARY) --cflags bcm_host` \
19 `$(PKG_CONFIG_HOST_BINARY) --cflags freetype2` \
20 `$(PKG_CONFIG_HOST_BINARY) --cflags dbus-1`
22 # OMXplayer has support for building in Buildroot, but that
23 # procedure is, well, tainted. Fix this by forcing the real,
24 # correct values.
25 OMXPLAYER_MAKE_ENV = \
26 USE_BUILDROOT=1 \
27 BUILDROOT=$(TOP_DIR) \
28 SDKSTAGE=$(STAGING_DIR) \
29 TARGETFS=$(TARGET_DIR) \
30 TOOLCHAIN=$(HOST_DIR)/usr \
31 HOST=$(GNU_TARGET_NAME) \
32 SYSROOT=$(STAGING_DIR) \
33 JOBS=$(PARALLEL_JOBS) \
34 $(TARGET_CONFIGURE_OPTS) \
35 STRIP=true \
36 CFLAGS="$(TARGET_CFLAGS) $(OMXPLAYER_EXTRA_CFLAGS)"
38 define OMXPLAYER_BUILD_CMDS
39 $(OMXPLAYER_MAKE_ENV) $(MAKE) -C $(@D) omxplayer.bin
40 endef
42 define OMXPLAYER_INSTALL_TARGET_CMDS
43 $(INSTALL) -m 0755 -D $(@D)/omxplayer.bin $(TARGET_DIR)/usr/bin/omxplayer
44 endef
46 $(eval $(generic-package))