1 ################################################################################
5 ################################################################################
7 OMXPLAYER_VERSION
= 6c90c7503ba4658221774759edf7f2ae816711de
8 OMXPLAYER_SITE
= $(call github
,popcornmix
,omxplayer
,$(OMXPLAYER_VERSION
))
9 OMXPLAYER_LICENSE
= GPLv2
+
10 OMXPLAYER_LICENSE_FILES
= COPYING
12 OMXPLAYER_DEPENDENCIES
= \
13 host-pkgconf boost dbus ffmpeg freetype libidn libusb pcre \
16 OMXPLAYER_EXTRA_CFLAGS
= \
17 -DTARGET_LINUX
-DTARGET_POSIX \
18 `$(PKG_CONFIG_HOST_BINARY) --cflags bcm_host` \
19 `$(PKG_CONFIG_HOST_BINARY) --cflags freetype2` \
20 `$(PKG_CONFIG_HOST_BINARY) --cflags dbus-1`
22 # OMXplayer has support for building in Buildroot, but that
23 # procedure is, well, tainted. Fix this by forcing the real,
25 OMXPLAYER_MAKE_ENV
= \
27 BUILDROOT
=$(TOP_DIR
) \
28 SDKSTAGE
=$(STAGING_DIR
) \
29 TARGETFS
=$(TARGET_DIR
) \
30 TOOLCHAIN
=$(HOST_DIR
)/usr \
31 HOST
=$(GNU_TARGET_NAME
) \
32 SYSROOT
=$(STAGING_DIR
) \
33 JOBS
=$(PARALLEL_JOBS
) \
34 $(TARGET_CONFIGURE_OPTS
) \
36 CFLAGS
="$(TARGET_CFLAGS) $(OMXPLAYER_EXTRA_CFLAGS)"
38 define OMXPLAYER_BUILD_CMDS
39 $(OMXPLAYER_MAKE_ENV
) $(MAKE
) -C
$(@D
) omxplayer.bin
42 define OMXPLAYER_INSTALL_TARGET_CMDS
43 $(INSTALL
) -m
0755 -D
$(@D
)/omxplayer.bin
$(TARGET_DIR
)/usr
/bin
/omxplayer
46 $(eval
$(generic-package
))