1 ################################################################################
5 ################################################################################
7 SUPERVISOR_VERSION
= 3.1.3
8 SUPERVISOR_SITE
= http
://pypi.python.org
/packages
/source
/s
/supervisor
9 SUPERVISOR_LICENSE
= BSD-like
, rdflib
(http_client.py
), PSF
(medusa
), ZPL-2.1
10 SUPERVISOR_LICENSE_FILES
= COPYRIGHT.txt LICENSES.txt
11 SUPERVISOR_SETUP_TYPE
= setuptools
13 define SUPERVISOR_INSTALL_CONF_FILES
14 $(INSTALL
) -d
-m
755 $(TARGET_DIR
)/etc
/supervisor.d
15 $(INSTALL
) -D
-m
644 package
/supervisor
/supervisord.conf \
16 $(TARGET_DIR
)/etc
/supervisord.conf
19 SUPERVISOR_POST_INSTALL_TARGET_HOOKS
+= SUPERVISOR_INSTALL_CONF_FILES
21 define SUPERVISOR_INSTALL_INIT_SYSV
22 $(INSTALL
) -D
-m
755 package
/supervisor
/S99supervisord \
23 $(TARGET_DIR
)/etc
/init.d
/S99supervisord
26 define SUPERVISOR_INSTALL_INIT_SYSTEMD
27 $(INSTALL
) -D
-m
644 package
/supervisor
/supervisord.service \
28 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/supervisord.service
29 mkdir
-p
$(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
30 ln
-sf ..
/..
/..
/..
/usr
/lib
/systemd
/system
/supervisord.service \
31 $(TARGET_DIR
)/etc
/systemd
/system
/multi-user.target.wants
/supervisord.service
34 $(eval
$(python-package
))