1 ################################################################################
5 ################################################################################
7 APACHE_VERSION
= 2.4.12
8 APACHE_SOURCE
= httpd-
$(APACHE_VERSION
).
tar.bz2
9 APACHE_SITE
= http
://archive.apache.org
/dist/httpd
10 APACHE_LICENSE
= Apache-2.0
11 APACHE_LICENSE_FILES
= LICENSE
13 APACHE_INSTALL_STAGING
= YES
14 # We have a patch touching configure.in and Makefile.in,
15 # so we need to autoreconf:
16 APACHE_AUTORECONF
= YES
17 APACHE_DEPENDENCIES
= apr apr-util pcre
20 ap_cv_void_ptr_lt_long
=no \
21 PCRE_CONFIG
=$(STAGING_DIR
)/usr
/bin
/pcre-config
24 --sysconfdir
=/etc
/apache2 \
25 --with-apr
=$(STAGING_DIR
)/usr \
26 --with-apr-util
=$(STAGING_DIR
)/usr \
27 --with-pcre
=$(STAGING_DIR
)/usr
/bin
/pcre-config \
32 --without-suexec-bin \
33 --enable-mods-shared
=all \
38 ifeq ($(BR2_ARCH_HAS_ATOMICS
),y
)
39 APACHE_CONF_OPTS
+= --enable-nonportable-atomics
=yes
42 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
43 APACHE_DEPENDENCIES
+= libxml2
44 # Apache wants the path to the header file, where it can find
49 --with-libxml2
=$(STAGING_DIR
)/usr
/include/libxml2
56 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
57 APACHE_DEPENDENCIES
+= openssl
60 --with-ssl
=$(STAGING_DIR
)/usr
62 APACHE_CONF_OPTS
+= --disable-ssl
65 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
66 APACHE_DEPENDENCIES
+= zlib
69 --with-z
=$(STAGING_DIR
)/usr
71 APACHE_CONF_OPTS
+= --disable-deflate
74 define APACHE_FIX_STAGING_APACHE_CONFIG
75 $(SED
) 's%/usr/build%$(STAGING_DIR)/usr/build%' $(STAGING_DIR
)/usr
/bin
/apxs
76 $(SED
) 's%^prefix =.*%prefix = $(STAGING_DIR)/usr%' $(STAGING_DIR
)/usr
/build
/config_vars.mk
78 APACHE_POST_INSTALL_STAGING_HOOKS
+= APACHE_FIX_STAGING_APACHE_CONFIG
80 define APACHE_CLEANUP_TARGET
81 $(RM
) -rf
$(TARGET_DIR
)/usr
/manual
$(TARGET_DIR
)/usr
/build
83 APACHE_POST_INSTALL_TARGET_HOOKS
+= APACHE_CLEANUP_TARGET
85 $(eval
$(autotools-package
))