open-plc-utils: new package
[buildroot-gz.git] / package / apache / apache.mk
blob296e27e9c67b82b947698859b901e65ee79c6649
1 ################################################################################
3 # apache
5 ################################################################################
7 APACHE_VERSION = 2.4.12
8 APACHE_SOURCE = httpd-$(APACHE_VERSION).tar.bz2
9 APACHE_SITE = http://archive.apache.org/dist/httpd
10 APACHE_LICENSE = Apache-2.0
11 APACHE_LICENSE_FILES = LICENSE
12 # Needed for mod_php
13 APACHE_INSTALL_STAGING = YES
14 # We have a patch touching configure.in and Makefile.in,
15 # so we need to autoreconf:
16 APACHE_AUTORECONF = YES
17 APACHE_DEPENDENCIES = apr apr-util pcre
19 APACHE_CONF_ENV= \
20 ap_cv_void_ptr_lt_long=no \
21 PCRE_CONFIG=$(STAGING_DIR)/usr/bin/pcre-config
23 APACHE_CONF_OPTS = \
24 --sysconfdir=/etc/apache2 \
25 --with-apr=$(STAGING_DIR)/usr \
26 --with-apr-util=$(STAGING_DIR)/usr \
27 --with-pcre=$(STAGING_DIR)/usr/bin/pcre-config \
28 --enable-http \
29 --enable-dbd \
30 --enable-proxy \
31 --enable-mime-magic \
32 --without-suexec-bin \
33 --enable-mods-shared=all \
34 --with-mpm=worker \
35 --disable-lua \
36 --disable-luajit
38 ifeq ($(BR2_ARCH_HAS_ATOMICS),y)
39 APACHE_CONF_OPTS += --enable-nonportable-atomics=yes
40 endif
42 ifeq ($(BR2_PACKAGE_LIBXML2),y)
43 APACHE_DEPENDENCIES += libxml2
44 # Apache wants the path to the header file, where it can find
45 # <libxml/parser.h>.
46 APACHE_CONF_OPTS += \
47 --enable-xml2enc \
48 --enable-proxy-html \
49 --with-libxml2=$(STAGING_DIR)/usr/include/libxml2
50 else
51 APACHE_CONF_OPTS += \
52 --disable-xml2enc \
53 --disable-proxy-html
54 endif
56 ifeq ($(BR2_PACKAGE_OPENSSL),y)
57 APACHE_DEPENDENCIES += openssl
58 APACHE_CONF_OPTS += \
59 --enable-ssl \
60 --with-ssl=$(STAGING_DIR)/usr
61 else
62 APACHE_CONF_OPTS += --disable-ssl
63 endif
65 ifeq ($(BR2_PACKAGE_ZLIB),y)
66 APACHE_DEPENDENCIES += zlib
67 APACHE_CONF_OPTS += \
68 --enable-deflate \
69 --with-z=$(STAGING_DIR)/usr
70 else
71 APACHE_CONF_OPTS += --disable-deflate
72 endif
74 define APACHE_FIX_STAGING_APACHE_CONFIG
75 $(SED) 's%/usr/build%$(STAGING_DIR)/usr/build%' $(STAGING_DIR)/usr/bin/apxs
76 $(SED) 's%^prefix =.*%prefix = $(STAGING_DIR)/usr%' $(STAGING_DIR)/usr/build/config_vars.mk
77 endef
78 APACHE_POST_INSTALL_STAGING_HOOKS += APACHE_FIX_STAGING_APACHE_CONFIG
80 define APACHE_CLEANUP_TARGET
81 $(RM) -rf $(TARGET_DIR)/usr/manual $(TARGET_DIR)/usr/build
82 endef
83 APACHE_POST_INSTALL_TARGET_HOOKS += APACHE_CLEANUP_TARGET
85 $(eval $(autotools-package))