open-plc-utils: new package
[buildroot-gz.git] / package / fio / fio.mk
blobf9a690e7cf63d18720bc614e332c69f9c953000a
1 ################################################################################
3 # fio
5 ################################################################################
7 FIO_VERSION = fio-2.1.4
8 FIO_SITE = git://git.kernel.dk/fio.git
9 FIO_LICENSE = GPLv2 + special obligations
10 FIO_LICENSE_FILES = LICENSE
12 define FIO_CONFIGURE_CMDS
13 (cd $(@D); ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
14 endef
16 define FIO_BUILD_CMDS
17 $(MAKE) -C $(@D)
18 endef
20 define FIO_INSTALL_TARGET_CMDS
21 $(INSTALL) -D $(@D)/fio $(TARGET_DIR)/usr/bin/fio
22 endef
24 $(eval $(generic-package))