1 ################################################################################
5 ################################################################################
8 IOZONE_SOURCE
= iozone
$(IOZONE_VERSION
).
tar
9 IOZONE_SITE
= http
://www.iozone.org
/src
/current
10 IOZONE_LICENSE
= IOzone license
(NO DERIVED WORKS ALLOWED
)
11 # IOzone license details can be found at:
12 # http://www.iozone.org/docs/Iozone_License.txt
14 # No threading target is non-AIO as well
15 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),)
16 IOZONE_TARGET
= linux-noth
17 # AIO support not available on uClibc, use the linux (non-aio) target.
18 else ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC
),y
)
19 IOZONE_TARGET
= linux-noaio
24 define IOZONE_BUILD_CMDS
25 $(MAKE
) $(TARGET_CONFIGURE_OPTS
) $(IOZONE_TARGET
) -C
$(@D
)/src
/current
28 define IOZONE_INSTALL_TARGET_CMDS
29 $(INSTALL
) -D
-m
755 $(@D
)/src
/current
/iozone \
30 $(TARGET_DIR
)/usr
/bin
/iozone
33 $(eval
$(generic-package
))