open-plc-utils: new package
[buildroot-gz.git] / package / monit / monit.mk
blob1a813492545523e9a2b1b6aba3b602344835292a
1 ################################################################################
3 # monit
5 ################################################################################
7 MONIT_VERSION = 5.7
8 MONIT_SITE = http://mmonit.com/monit/dist
9 MONIT_LICENSE = AGPLv3 with OpenSSL exception
10 MONIT_LICENSE_FILES = COPYING
12 # Touching Makefile.am:
13 MONIT_AUTORECONF = YES
15 # Missing m4/ directory in the source tree
16 define MONIT_M4
17 mkdir $(@D)/m4
18 endef
19 MONIT_POST_PATCH_HOOKS += MONIT_M4
21 MONIT_CONF_ENV = \
22 libmonit_cv_setjmp_available=yes \
23 libmonit_cv_vsnprintf_c99_conformant=yes
25 MONIT_CONF_OPTS += \
26 --without-pam \
27 --with-largefiles
29 ifeq ($(BR2_PACKAGE_OPENSSL),y)
30 MONIT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
31 MONIT_DEPENDENCIES += openssl
32 else
33 MONIT_CONF_OPTS += --without-ssl
34 endif
36 $(eval $(autotools-package))