1 ################################################################################
5 ################################################################################
8 OLA_SITE
= $(call github
,OpenLightingProject
,ola
,$(OLA_VERSION
))
10 OLA_LICENSE
= LGPLv2.1
+ (libola
, libolacommon
, Python bindings
), GPLv2
+ (libolaserver
, olad
, Python examples and tests
)
11 OLA_LICENSE_FILES
= LICENCE GPL LGPL
12 OLA_INSTALL_STAGING
= YES
15 # util-linux provides uuid lib
16 OLA_DEPENDENCIES
= protobuf util-linux host-bison host-flex host-ola
19 ac_cv_have_pymod_google_protobuf
=yes \
23 --disable-root-check \
25 --disable-fatal-warnings \
26 --with-ola-protoc-plugin
=$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
28 HOST_OLA_DEPENDENCIES
= host-util-linux host-protobuf
30 # When building the host part, disable as much as possible to speed up
31 # the configure step and avoid missing host dependencies.
32 HOST_OLA_CONF_OPTS
= \
33 --disable-all-plugins \
42 --disable-doxygen-html \
45 # On the host side, we only need ola_protoc_plugin, so build and install this
47 HOST_OLA_MAKE_OPTS
= protoc
/ola_protoc_plugin
48 define HOST_OLA_INSTALL_CMDS
49 $(INSTALL
) -D
-m
0755 $(@D
)/protoc
/ola_protoc_plugin
$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
52 # sets where to find python libs built for target and required by ola
53 OLA_CONF_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
54 OLA_MAKE_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
56 ## OLA Bindings and Interface selections
58 ifeq ($(BR2_PACKAGE_OLA_WEB
),y
)
59 OLA_CONF_OPTS
+= --enable-http
60 OLA_DEPENDENCIES
+= libmicrohttpd
62 OLA_CONF_OPTS
+= --disable-http
65 ifeq ($(BR2_PACKAGE_OLA_SLP
),y
)
66 OLA_CONF_OPTS
+= --enable-slp
68 OLA_CONF_OPTS
+= --disable-slp
71 ifeq ($(BR2_PACKAGE_OLA_PYTHON_BINDINGS
),y
)
72 OLA_CONF_OPTS
+= --enable-python-libs
73 OLA_DEPENDENCIES
+= python python-protobuf
75 OLA_CONF_OPTS
+= --disable-python-libs
78 ## OLA Examples and Tests
80 ifeq ($(BR2_PACKAGE_OLA_EXAMPLES
),y
)
81 OLA_CONF_OPTS
+= --enable-examples
82 OLA_DEPENDENCIES
+= ncurses
84 OLA_CONF_OPTS
+= --disable-examples
87 ifeq ($(BR2_PACKAGE_OLA_RDM_TESTS
),y
)
88 OLA_CONF_OPTS
+= --enable-rdm-tests
90 OLA_CONF_OPTS
+= --disable-rdm-tests
93 ## OLA Plugin selections
95 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_E131
),y
)
96 OLA_CONF_OPTS
+= --enable-e131
98 OLA_CONF_OPTS
+= --disable-e131
101 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ARTNET
),y
)
102 OLA_CONF_OPTS
+= --enable-artnet
104 OLA_CONF_OPTS
+= --disable-artnet
107 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OPENDMX
),y
)
108 OLA_CONF_OPTS
+= --enable-opendmx
110 OLA_CONF_OPTS
+= --disable-opendmx
113 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_DUMMY
),y
)
114 OLA_CONF_OPTS
+= --enable-dummy
116 OLA_CONF_OPTS
+= --disable-dummy
119 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ESPNET
),y
)
120 OLA_CONF_OPTS
+= --enable-espnet
122 OLA_CONF_OPTS
+= --disable-espnet
125 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_KINET
),y
)
126 OLA_CONF_OPTS
+= --enable-kinet
128 OLA_CONF_OPTS
+= --disable-kinet
131 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OSC
),y
)
132 OLA_CONF_OPTS
+= --enable-osc
133 OLA_DEPENDENCIES
+= liblo
135 OLA_CONF_OPTS
+= --disable-osc
138 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_MILINT
),y
)
139 OLA_CONF_OPTS
+= --enable-milinst
141 OLA_CONF_OPTS
+= --disable-milinst
144 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_PATHPORT
),y
)
145 OLA_CONF_OPTS
+= --enable-pathport
147 OLA_CONF_OPTS
+= --disable-pathport
150 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SANDNET
),y
)
151 OLA_CONF_OPTS
+= --enable-sandnet
153 OLA_CONF_OPTS
+= --disable-sandnet
156 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SHOWNET
),y
)
157 OLA_CONF_OPTS
+= --enable-shownet
159 OLA_CONF_OPTS
+= --disable-shownet
162 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_STAGEPROFI
),y
)
163 OLA_CONF_OPTS
+= --enable-stageprofi
--enable-libusb
165 OLA_CONF_OPTS
+= --disable-stageprofi
168 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_USBPRO
),y
)
169 OLA_CONF_OPTS
+= --enable-usbpro
--enable-libusb
171 OLA_CONF_OPTS
+= --disable-usbpro
174 $(eval
$(autotools-package
))
175 $(eval
$(host-autotools-package
))