open-plc-utils: new package
[buildroot-gz.git] / package / php-ssh2 / php-ssh2.mk
blobace68e01fda7a5f0aba8cb6cb2cbe828d51d3944
1 ################################################################################
3 # php-ssh2
5 ################################################################################
7 PHP_SSH2_VERSION = 0.12
8 PHP_SSH2_SOURCE = ssh2-$(PHP_SSH2_VERSION).tgz
9 # pecl.php.net returns html with db connect failed
10 PHP_SSH2_SITE = http://sources.buildroot.net
11 PHP_SSH2_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
12 --with-ssh2=$(STAGING_DIR)/usr
13 # phpize does the autoconf magic
14 PHP_SSH2_DEPENDENCIES = libssh2 php host-autoconf
15 PHP_SSH2_LICENSE = PHP
16 PHP_SSH2_LICENSE_FILES = LICENSE
18 define PHP_SSH2_PHPIZE
19 (cd $(@D); \
20 PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
21 PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
22 $(STAGING_DIR)/usr/bin/phpize)
23 endef
25 PHP_SSH2_PRE_CONFIGURE_HOOKS += PHP_SSH2_PHPIZE
27 $(eval $(autotools-package))