1 ################################################################################
5 ################################################################################
7 PIXMAN_VERSION
= 0.32.6
8 PIXMAN_SITE
= http
://xorg.freedesktop.org
/releases
/individual
/lib
10 PIXMAN_LICENSE_FILES
= COPYING
12 PIXMAN_INSTALL_STAGING
= YES
13 PIXMAN_DEPENDENCIES
= host-pkgconf
14 PIXMAN_AUTORECONF
= YES
16 # don't build gtk based demos
17 PIXMAN_CONF_OPTS
= --disable-gtk
19 # disable iwmmxt support for CPU's that don't have
21 ifneq ($(BR2_iwmmxt
),y
)
22 PIXMAN_CONF_OPTS
+= --disable-arm-iwmmxt
25 # toolchain gets confused about TLS access through GOT (PIC), so disable TLS
26 # movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
27 # {standard input}:172: Error: bad expression
28 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
),y
)
29 PIXMAN_CONF_ENV
+= CFLAGS
="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
32 $(eval
$(autotools-package
))
33 $(eval
$(host-autotools-package
))