open-plc-utils: new package
[buildroot-gz.git] / package / sstrip / sstrip.mk
blobfe57b3c19b21110a6278cadc915c2fd383ecfa95
1 ################################################################################
3 # sstrip
5 ################################################################################
7 SSTRIP_SITE = svn://svn.openwrt.org/openwrt/trunk/tools/sstrip
8 SSTRIP_VERSION = 20154
9 HOST_SSTRIP_BINARY = $(GNU_TARGET_NAME)-sstrip
11 define SSTRIP_BUILD_CMDS
12 cd $(@D) ; \
13 $(TARGET_CC) $(TARGET_CFLAGS) -include endian.h -include byteswap.h \
14 -o sstrip src/sstrip.c
15 endef
17 define SSTRIP_INSTALL_TARGET_CMDS
18 $(INSTALL) -D $(@D)/sstrip $(TARGET_DIR)/usr/bin/sstrip
19 endef
21 define HOST_SSTRIP_BUILD_CMDS
22 cd $(@D) ; \
23 $(HOSTCC) $(HOST_CFLAGS) -include endian.h -include byteswap.h \
24 -o sstrip src/sstrip.c
25 endef
27 define HOST_SSTRIP_INSTALL_CMDS
28 $(INSTALL) -D $(@D)/sstrip $(HOST_DIR)/usr/bin/$(HOST_SSTRIP_BINARY)
29 endef
31 $(eval $(generic-package))
32 $(eval $(host-generic-package))