1 ################################################################################
5 ################################################################################
8 SWIG_VERSION
= $(SWIG_MAJOR
).12
9 SWIG_SITE
= http
://downloads.sourceforge.net
/project
/swig
/swig
/swig-
$(SWIG_VERSION
)
10 SWIG_DEPENDENCIES
= host-bison
11 HOST_SWIG_CONF_OPTS
= \
15 SWIG_LICENSE
= GPLv3
+ BSD-2c BSD-3c
16 SWIG_LICENSE_FILES
= LICENSE LICENSE-GPL LICENSE-UNIVERSITIES
18 # CMake looks first at swig2.0 and then swig. However, when doing the
19 # search, it will look into the PATH for swig2.0 first, and then for
20 # swig. While the PATH contains first our $(HOST_DIR)/usr/bin, it also
21 # contains /usr/bin and other system directories. Therefore, if there
22 # is an installed swig2.0 on the system, it will get the preference
23 # over the swig installed in $(HOST_DIR)/usr/bin, which isn't nice. To
24 # prevent this from happening we create a symbolic link swig2.0 ->
25 # swig, so that our swig always gets used.
27 define HOST_SWIG_INSTALL_SYMLINK
28 ln
-fs
$(HOST_DIR
)/usr
/bin
/swig
$(HOST_DIR
)/usr
/bin
/swig
$(SWIG_MAJOR
)
31 HOST_SWIG_POST_INSTALL_HOOKS
+= HOST_SWIG_INSTALL_SYMLINK
33 $(eval
$(host-autotools-package
))
35 SWIG
= $(HOST_DIR
)/usr
/bin
/swig
$(SWIG_MAJOR
)