1 ################################################################################
5 ################################################################################
7 JACK2_VERSION
= v1.9
.10
8 JACK2_SITE
= $(call github
,jackaudio
,jack2
,$(JACK2_VERSION
))
9 JACK2_LICENSE
= GPLv2
+ (jack server
), LGPLv2.1
+ (jack library
)
10 JACK2_DEPENDENCIES
= libsamplerate libsndfile alsa-lib host-python
11 JACK2_INSTALL_STAGING
= YES
12 JACK2_PATCH
= https
://github.com
/jackaudio
/jack2
/commit
/ff1ed2c4524095055140370c1008a2d9cccc5645.patch
14 JACK2_CONF_OPTS
= --alsa
16 ifeq ($(BR2_PACKAGE_OPUS
),y
)
17 JACK2_DEPENDENCIES
+= opus
20 ifeq ($(BR2_PACKAGE_READLINE
),y
)
21 JACK2_DEPENDENCIES
+= readline
24 ifeq ($(BR2_PACKAGE_JACK2_LEGACY
),y
)
25 JACK2_CONF_OPTS
+= --classic
27 define JACK2_REMOVE_JACK_CONTROL
28 $(RM
) -f
$(TARGET_DIR
)/usr
/bin
/jack_control
30 JACK2_POST_INSTALL_TARGET_HOOKS
+= JACK2_REMOVE_JACK_CONTROL
33 ifeq ($(BR2_PACKAGE_JACK2_DBUS
),y
)
34 JACK2_DEPENDENCIES
+= dbus
35 JACK2_CONF_OPTS
+= --dbus
38 # Even though it advertises support for celt-0.5.x, jack2 really
39 # requires celt >= 0.5.2 but we only have 0.5.1.3 and we cannot
40 # upgrade, so we do not add a dependency to celt051, which it can't
41 # find anyway as it looks for celt.pc but we only have celt-51.pc.
43 # The dependency against eigen is only useful in conjunction with
44 # gtkiostream, which we do not have, so we don't need to depend on
47 $(eval
$(waf-package
))