1 ################################################################################
5 ################################################################################
7 MEDIASTREAMER_VERSION
= 2.14.0
8 MEDIASTREAMER_SITE
= http
://download.savannah.nongnu.org
/releases
/linphone
/mediastreamer
9 MEDIASTREAMER_INSTALL_STAGING
= YES
10 MEDIASTREAMER_DEPENDENCIES
= host-intltool host-pkgconf ortp host-gettext
11 # tests fail linking on some architectures, so disable them
12 MEDIASTREAMER_CONF_OPTS
= --disable-tests
--disable-glx
--disable-strict
13 MEDIASTREAMER_LICENSE
= GPLv2
+
14 MEDIASTREAMER_LICENSE_FILES
= COPYING
16 # fix compilation issue with latest bctoolbox (touches configure.ac)
17 MEDIASTREAMER_PATCH
= \
18 https
://github.com
/BelledonneCommunications
/mediastreamer2
/commit
/26f884bf977977041fe6f98a0af186be1580bf22.patch
20 # patching configure.ac
21 MEDIASTREAMER_AUTORECONF
= YES
23 ifeq ($(BR2_PACKAGE_ALSA_LIB_MIXER
)$(BR2_PACKAGE_ALSA_LIB_PCM
),yy
)
24 MEDIASTREAMER_CONF_OPTS
+= --enable-alsa
25 MEDIASTREAMER_DEPENDENCIES
+= alsa-lib
27 MEDIASTREAMER_CONF_OPTS
+= --disable-alsa
30 ifeq ($(BR2_PACKAGE_LIBUPNP
),y
)
31 MEDIASTREAMER_CONF_OPTS
+= --enable-upnp
32 MEDIASTREAMER_DEPENDENCIES
+= libupnp
34 MEDIASTREAMER_CONF_OPTS
+= --disable-upnp
37 ifeq ($(BR2_PACKAGE_LIBVPX
),y
)
38 MEDIASTREAMER_CONF_OPTS
+= --enable-vp8
39 MEDIASTREAMER_DEPENDENCIES
+= libvpx
41 MEDIASTREAMER_CONF_OPTS
+= --disable-vp8
44 ifeq ($(BR2_PACKAGE_OPUS
),y
)
45 MEDIASTREAMER_CONF_OPTS
+= --enable-opus
46 MEDIASTREAMER_DEPENDENCIES
+= opus
48 MEDIASTREAMER_CONF_OPTS
+= --disable-opus
51 # portaudio backend needs speex as well
52 ifeq ($(BR2_PACKAGE_PORTAUDIO
)$(BR2_PACKAGE_SPEEX
),yy
)
53 MEDIASTREAMER_CONF_OPTS
+= --enable-portaudio
54 MEDIASTREAMER_DEPENDENCIES
+= portaudio speex
56 MEDIASTREAMER_CONF_OPTS
+= --disable-portaudio
59 ifeq ($(BR2_PACKAGE_PULSEAUDIO
),y
)
60 MEDIASTREAMER_CONF_OPTS
+= --enable-pulseaudio
61 MEDIASTREAMER_DEPENDENCIES
+= pulseaudio
63 MEDIASTREAMER_CONF_OPTS
+= --disable-pulseaudio
66 ifeq ($(BR2_PACKAGE_SPEEX
),y
)
67 MEDIASTREAMER_CONF_OPTS
+= --enable-speex
68 MEDIASTREAMER_DEPENDENCIES
+= speex
70 MEDIASTREAMER_CONF_OPTS
+= --disable-speex
73 ifeq ($(BR2_PACKAGE_FFMPEG_SWSCALE
),y
)
74 MEDIASTREAMER_CONF_OPTS
+= --enable-ffmpeg
75 MEDIASTREAMER_DEPENDENCIES
+= ffmpeg
77 MEDIASTREAMER_CONF_OPTS
+= --disable-ffmpeg
80 ifeq ($(BR2_PACKAGE_SDL
),y
)
81 MEDIASTREAMER_CONF_OPTS
+= --enable-sdl
82 MEDIASTREAMER_DEPENDENCIES
+= sdl
84 MEDIASTREAMER_CONF_OPTS
+= --disable-sdl
87 # mediastreamer assumes SDL has X11 support if --enable-x11 (and X11 support
88 # is only used for SDL output)
89 ifeq ($(BR2_PACKAGE_SDL_X11
),y
)
90 MEDIASTREAMER_CONF_OPTS
+= --enable-x11
92 MEDIASTREAMER_CONF_OPTS
+= --disable-x11
95 ifeq ($(BR2_PACKAGE_XLIB_LIBXV
),y
)
96 MEDIASTREAMER_CONF_OPTS
+= --enable-xv
97 MEDIASTREAMER_DEPENDENCIES
+= xlib_libXv
99 MEDIASTREAMER_CONF_OPTS
+= --disable-xv
102 ifeq ($(BR2_PACKAGE_LIBTHEORA
),y
)
103 MEDIASTREAMER_CONF_OPTS
+= --enable-theora
104 MEDIASTREAMER_DEPENDENCIES
+= libtheora
106 MEDIASTREAMER_CONF_OPTS
+= --disable-theora
109 ifeq ($(BR2_PACKAGE_LIBV4L
),y
)
110 MEDIASTREAMER_CONF_OPTS
+= --enable-libv4l1
--enable-libv4l2
111 MEDIASTREAMER_DEPENDENCIES
+= libv4l
113 MEDIASTREAMER_CONF_OPTS
+= --disable-libv4l1
--disable-libv4l2
116 $(eval
$(autotools-package
))