boost: bump to version 1.63.0
[buildroot-gz.git] / package / mediastreamer / mediastreamer.mk
blobb4f0c52c7c154f165d71809531528d3a131d87f0
1 ################################################################################
3 # mediastreamer
5 ################################################################################
7 MEDIASTREAMER_VERSION = 2.14.0
8 MEDIASTREAMER_SITE = http://download.savannah.nongnu.org/releases/linphone/mediastreamer
9 MEDIASTREAMER_INSTALL_STAGING = YES
10 MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext
11 # tests fail linking on some architectures, so disable them
12 MEDIASTREAMER_CONF_OPTS = --disable-tests --disable-glx --disable-strict
13 MEDIASTREAMER_LICENSE = GPLv2+
14 MEDIASTREAMER_LICENSE_FILES = COPYING
16 # fix compilation issue with latest bctoolbox (touches configure.ac)
17 MEDIASTREAMER_PATCH = \
18 https://github.com/BelledonneCommunications/mediastreamer2/commit/26f884bf977977041fe6f98a0af186be1580bf22.patch
20 # patching configure.ac
21 MEDIASTREAMER_AUTORECONF = YES
23 ifeq ($(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yy)
24 MEDIASTREAMER_CONF_OPTS += --enable-alsa
25 MEDIASTREAMER_DEPENDENCIES += alsa-lib
26 else
27 MEDIASTREAMER_CONF_OPTS += --disable-alsa
28 endif
30 ifeq ($(BR2_PACKAGE_LIBUPNP),y)
31 MEDIASTREAMER_CONF_OPTS += --enable-upnp
32 MEDIASTREAMER_DEPENDENCIES += libupnp
33 else
34 MEDIASTREAMER_CONF_OPTS += --disable-upnp
35 endif
37 ifeq ($(BR2_PACKAGE_LIBVPX),y)
38 MEDIASTREAMER_CONF_OPTS += --enable-vp8
39 MEDIASTREAMER_DEPENDENCIES += libvpx
40 else
41 MEDIASTREAMER_CONF_OPTS += --disable-vp8
42 endif
44 ifeq ($(BR2_PACKAGE_OPUS),y)
45 MEDIASTREAMER_CONF_OPTS += --enable-opus
46 MEDIASTREAMER_DEPENDENCIES += opus
47 else
48 MEDIASTREAMER_CONF_OPTS += --disable-opus
49 endif
51 # portaudio backend needs speex as well
52 ifeq ($(BR2_PACKAGE_PORTAUDIO)$(BR2_PACKAGE_SPEEX),yy)
53 MEDIASTREAMER_CONF_OPTS += --enable-portaudio
54 MEDIASTREAMER_DEPENDENCIES += portaudio speex
55 else
56 MEDIASTREAMER_CONF_OPTS += --disable-portaudio
57 endif
59 ifeq ($(BR2_PACKAGE_PULSEAUDIO),y)
60 MEDIASTREAMER_CONF_OPTS += --enable-pulseaudio
61 MEDIASTREAMER_DEPENDENCIES += pulseaudio
62 else
63 MEDIASTREAMER_CONF_OPTS += --disable-pulseaudio
64 endif
66 ifeq ($(BR2_PACKAGE_SPEEX),y)
67 MEDIASTREAMER_CONF_OPTS += --enable-speex
68 MEDIASTREAMER_DEPENDENCIES += speex
69 else
70 MEDIASTREAMER_CONF_OPTS += --disable-speex
71 endif
73 ifeq ($(BR2_PACKAGE_FFMPEG_SWSCALE),y)
74 MEDIASTREAMER_CONF_OPTS += --enable-ffmpeg
75 MEDIASTREAMER_DEPENDENCIES += ffmpeg
76 else
77 MEDIASTREAMER_CONF_OPTS += --disable-ffmpeg
78 endif
80 ifeq ($(BR2_PACKAGE_SDL),y)
81 MEDIASTREAMER_CONF_OPTS += --enable-sdl
82 MEDIASTREAMER_DEPENDENCIES += sdl
83 else
84 MEDIASTREAMER_CONF_OPTS += --disable-sdl
85 endif
87 # mediastreamer assumes SDL has X11 support if --enable-x11 (and X11 support
88 # is only used for SDL output)
89 ifeq ($(BR2_PACKAGE_SDL_X11),y)
90 MEDIASTREAMER_CONF_OPTS += --enable-x11
91 else
92 MEDIASTREAMER_CONF_OPTS += --disable-x11
93 endif
95 ifeq ($(BR2_PACKAGE_XLIB_LIBXV),y)
96 MEDIASTREAMER_CONF_OPTS += --enable-xv
97 MEDIASTREAMER_DEPENDENCIES += xlib_libXv
98 else
99 MEDIASTREAMER_CONF_OPTS += --disable-xv
100 endif
102 ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
103 MEDIASTREAMER_CONF_OPTS += --enable-theora
104 MEDIASTREAMER_DEPENDENCIES += libtheora
105 else
106 MEDIASTREAMER_CONF_OPTS += --disable-theora
107 endif
109 ifeq ($(BR2_PACKAGE_LIBV4L),y)
110 MEDIASTREAMER_CONF_OPTS += --enable-libv4l1 --enable-libv4l2
111 MEDIASTREAMER_DEPENDENCIES += libv4l
112 else
113 MEDIASTREAMER_CONF_OPTS += --disable-libv4l1 --disable-libv4l2
114 endif
116 $(eval $(autotools-package))