1 ################################################################################
5 ################################################################################
8 TOR_SITE
= https
://dist.torproject.org
10 TOR_LICENSE_FILES
= LICENSE
11 TOR_DEPENDENCIES
= libevent openssl zlib
15 --disable-gcc-hardening \
17 --with-libevent-dir
=$(STAGING_DIR
)/usr \
18 --with-openssl-dir
=$(STAGING_DIR
)/usr \
19 --with-zlib-dir
=$(STAGING_DIR
)/usr
21 ifeq ($(BR2_STATIC_LIBS
),y
)
23 --enable-static-libevent \
24 --enable-static-openssl \
29 ifeq ($(BR2_PACKAGE_LIBCAP
),y
)
30 TOR_DEPENDENCIES
+= libcap
33 ifeq ($(BR2_arm
)$(BR2_armeb
)$(BR2_i386
)$(BR2_x86_64
)$(BR2_PACKAGE_LIBSECCOMP
),yy
)
34 TOR_CONF_OPTS
+= --enable-seccomp
35 TOR_DEPENDENCIES
+= libseccomp
37 TOR_CONF_OPTS
+= --disable-seccomp
41 TOR_CONF_ENV
= ac_cv_prog_cc_c99
='-std=gnu99'
43 $(eval
$(autotools-package
))