boost: bump to version 1.63.0
[buildroot-gz.git] / package / tor / tor.mk
blobbb0fbb16b546dbb55a069c14e373aa5df61a34ea
1 ################################################################################
3 # tor
5 ################################################################################
7 TOR_VERSION = 0.2.9.9
8 TOR_SITE = https://dist.torproject.org
9 TOR_LICENSE = BSD-3c
10 TOR_LICENSE_FILES = LICENSE
11 TOR_DEPENDENCIES = libevent openssl zlib
12 TOR_AUTORECONF = YES
14 TOR_CONF_OPTS = \
15 --disable-gcc-hardening \
16 --disable-unittests \
17 --with-libevent-dir=$(STAGING_DIR)/usr \
18 --with-openssl-dir=$(STAGING_DIR)/usr \
19 --with-zlib-dir=$(STAGING_DIR)/usr
21 ifeq ($(BR2_STATIC_LIBS),y)
22 TOR_CONF_OPTS += \
23 --enable-static-libevent \
24 --enable-static-openssl \
25 --enable-static-tor \
26 --enable-static-zlib
27 endif
29 ifeq ($(BR2_PACKAGE_LIBCAP),y)
30 TOR_DEPENDENCIES += libcap
31 endif
33 ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
34 TOR_CONF_OPTS += --enable-seccomp
35 TOR_DEPENDENCIES += libseccomp
36 else
37 TOR_CONF_OPTS += --disable-seccomp
38 endif
40 # uses gnu extensions
41 TOR_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
43 $(eval $(autotools-package))