libpng: bump to version 1.6.23
[buildroot-gz.git] / package / mc / mc.mk
blob808f81c35130cd4f484b322549af09ba586a9553
1 ################################################################################
3 # mc
5 ################################################################################
7 MC_VERSION = 4.8.17
8 MC_SOURCE = mc-$(MC_VERSION).tar.xz
9 MC_SITE = http://ftp.midnight-commander.org
10 MC_LICENSE = GPLv3+
11 MC_LICENSE_FILES = COPYING
12 MC_DEPENDENCIES = libglib2 host-pkgconf
14 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
15 MC_CONF_OPTS += --enable-vfs-sftp
16 MC_DEPENDENCIES += libssh2
17 else
18 MC_CONF_OPTS += --disable-vfs-sftp
19 endif
21 # mc prefers slang, so use that if enabled, otherwise
22 # fallback to using ncurses.
23 # Either or both will be enabled, but we prefer slang.
24 ifeq ($(BR2_PACKAGE_SLANG),y)
25 MC_DEPENDENCIES += slang
26 MC_CONF_OPTS += --with-screen=slang
27 else
28 MC_DEPENDENCIES += ncurses
29 MC_CONF_OPTS += --with-screen=ncurses
30 endif
32 ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
33 MC_CONF_OPTS += --with-x
34 MC_DEPENDENCIES += xlib_libX11
35 else
36 MC_CONF_OPTS += --without-x
37 endif
39 $(eval $(autotools-package))