libpng: bump to version 1.6.23
[buildroot-gz.git] / package / tar / tar.mk
blob767c02f9f9908d7dbc2fc0193eac6e9a6cc9df62
1 ################################################################################
3 # tar
5 ################################################################################
7 TAR_VERSION = 1.29
8 TAR_SOURCE = tar-$(TAR_VERSION).tar.xz
9 TAR_SITE = $(BR2_GNU_MIRROR)/tar
10 # busybox installs in /bin, so we need tar to install as well in /bin
11 # so that it overrides the Busybox symlinks.
12 TAR_CONF_OPTS = --exec-prefix=/
13 TAR_LICENSE = GPLv3+
14 TAR_LICENSE_FILES = COPYING
16 # Prefer full-blown tar over buybox's version
17 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
18 TAR_DEPENDENCIES += busybox
19 HOST_TAR_DEPENDENCIES =
20 endif
22 ifeq ($(BR2_PACKAGE_ACL),y)
23 TAR_DEPENDENCIES += acl
24 TAR_CONF_OPTS += --with-posix-acls
25 else
26 TAR_CONF_OPTS += --without-posix-acls
27 endif
29 ifeq ($(BR2_PACKAGE_ATTR),y)
30 TAR_DEPENDENCIES += attr
31 TAR_CONF_OPTS += --with-xattrs
32 else
33 TAR_CONF_OPTS += --without-xattrs
34 endif
36 $(eval $(autotools-package))
38 # host-tar: use cpio.gz instead of tar.gz to prevent chicken-egg problem
39 # of needing tar to build tar.
40 HOST_TAR_SOURCE = tar-$(TAR_VERSION).cpio.gz
41 define HOST_TAR_EXTRACT_CMDS
42 mkdir -p $(@D)
43 cd $(@D) && \
44 $(call suitable-extractor,$(HOST_TAR_SOURCE)) $(DL_DIR)/$(HOST_TAR_SOURCE) | cpio -i --preserve-modification-time
45 mv $(@D)/tar-$(TAR_VERSION)/* $(@D)
46 rmdir $(@D)/tar-$(TAR_VERSION)
47 endef
48 $(eval $(host-autotools-package))