jpeg-turbo: fix legal info
[buildroot-gz.git] / package / sg3_utils / sg3_utils.mk
blobe7af83a523ca406ec6a6fe5a56095c210e3fd94e
1 ################################################################################
3 # sg3_utils
5 ################################################################################
7 SG3_UTILS_VERSION = 1.42
8 SG3_UTILS_SOURCE = sg3_utils-$(SG3_UTILS_VERSION).tar.xz
9 SG3_UTILS_SITE = http://sg.danny.cz/sg/p
10 SG3_UTILS_LICENSE = BSD-3c
11 # utils progs are GPLv2+ licenced
12 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),y)
13 SG3_UTILS_LICENSE += GPLv2+
14 endif
15 SG3_UTILS_LICENSE_FILES = COPYING BSD_LICENSE
17 # Patching configure.ac
18 SG3_UTILS_AUTORECONF = YES
20 # install the libsgutils2 library
21 SG3_UTILS_INSTALL_STAGING = YES
23 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),)
24 define SG3_UTILS_REMOVE_PROGS
25 for prog in \
26 compare_and_write copy_results dd decode_sense \
27 emc_trespass format get_config \
28 get_lba_status ident inq logs luns map26 \
29 map sgm_dd modes opcodes sgp_dd persist prevent \
30 raw rbuf rdac read readcap read_block_limits \
31 read_attr read_buffer read_long reassign referrals \
32 rep_zones requests reset reset_wp rmsn rtpg safte sanitize \
33 sat_identify sat_phy_event sat_read_gplog sat_set_features \
34 scan senddiag ses ses_microcode start stpg sync test_rwbuf \
35 timestamp turs unmap verify vpd write_buffer write_long \
36 write_same write_verify wr_mode xcopy zone; do \
37 $(RM) $(TARGET_DIR)/usr/bin/sg_$${prog} ; \
38 done
39 for prog in \
40 logging_level mandat readcap ready satl start stop \
41 temperature; do \
42 $(RM) $(TARGET_DIR)/usr/bin/scsi_$${prog} ; \
43 done
44 for prog in \
45 sginfo sgm_dd sgp_dd; do \
46 $(RM) $(TARGET_DIR)/usr/bin/$${prog}; \
47 done
48 endef
50 SG3_UTILS_POST_INSTALL_TARGET_HOOKS += SG3_UTILS_REMOVE_PROGS
51 endif
53 $(eval $(autotools-package))