1 ################################################################################
5 ################################################################################
7 SG3_UTILS_VERSION
= 1.42
8 SG3_UTILS_SOURCE
= sg3_utils-
$(SG3_UTILS_VERSION
).
tar.xz
9 SG3_UTILS_SITE
= http
://sg.danny.cz
/sg
/p
10 SG3_UTILS_LICENSE
= BSD-3c
11 # utils progs are GPLv2+ licenced
12 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS
),y
)
13 SG3_UTILS_LICENSE
+= GPLv2
+
15 SG3_UTILS_LICENSE_FILES
= COPYING BSD_LICENSE
17 # Patching configure.ac
18 SG3_UTILS_AUTORECONF
= YES
20 # install the libsgutils2 library
21 SG3_UTILS_INSTALL_STAGING
= YES
23 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS
),)
24 define SG3_UTILS_REMOVE_PROGS
26 compare_and_write copy_results dd decode_sense \
27 emc_trespass format get_config \
28 get_lba_status ident inq logs luns map26 \
29 map sgm_dd modes opcodes sgp_dd persist prevent \
30 raw rbuf rdac read readcap read_block_limits \
31 read_attr read_buffer read_long reassign referrals \
32 rep_zones requests reset reset_wp rmsn rtpg safte sanitize \
33 sat_identify sat_phy_event sat_read_gplog sat_set_features \
34 scan senddiag ses ses_microcode start stpg sync test_rwbuf \
35 timestamp turs unmap verify vpd write_buffer write_long \
36 write_same write_verify wr_mode xcopy zone
; do \
37 $(RM
) $(TARGET_DIR
)/usr
/bin
/sg_
$${prog} ; \
40 logging_level mandat readcap ready satl start stop \
42 $(RM
) $(TARGET_DIR
)/usr
/bin
/scsi_
$${prog} ; \
45 sginfo sgm_dd sgp_dd
; do \
46 $(RM
) $(TARGET_DIR
)/usr
/bin
/$${prog}; \
50 SG3_UTILS_POST_INSTALL_TARGET_HOOKS
+= SG3_UTILS_REMOVE_PROGS
53 $(eval
$(autotools-package
))