janus-gateway: make streaming plugin optional
[buildroot-gz.git] / package / janus-gateway / janus-gateway.mk
blob96a81fea353c6bd316685843fdce2d30d7a96887
1 ################################################################################
3 # janus-gateway
5 ################################################################################
7 JANUS_GATEWAY_VERSION = v0.2.1
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPLv3
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14 libsrtp host-gengetopt libglib2 openssl
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
20 define JANUS_GATEWAY_M4
21 mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
25 JANUS_GATEWAY_CONF_OPTS = \
26 --disable-data-channels \
27 --disable-rabbitmq
29 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE),y)
30 JANUS_GATEWAY_DEPENDENCIES += opus
31 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
32 else
33 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
34 endif
36 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST),y)
37 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
38 else
39 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
40 endif
42 ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY),y)
43 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
44 else
45 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
46 endif
48 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
49 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
50 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
51 else
52 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
53 endif
55 ifeq ($(BR2_PACKAGE_JANUS_STREAMING),y)
56 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
57 else
58 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
59 endif
61 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
62 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
63 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
64 else
65 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
66 endif
68 ifeq ($(BR2_PACKAGE_LIBOGG),y)
69 JANUS_GATEWAY_DEPENDENCIES += libogg
70 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
71 else
72 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
73 endif
75 # Parallel build broken
76 JANUS_GATEWAY_MAKE = $(MAKE1)
78 $(eval $(autotools-package))