wireshark: security bump to version 2.2.4
[buildroot-gz.git] / package / gcr / gcr.mk
blobd8cb667d157567b667ec50e583a5a630677905da
1 ################################################################################
3 # gcr
5 ################################################################################
7 GCR_VERSION_MAJOR = 3.20
8 GCR_VERSION = $(GCR_VERSION_MAJOR).0
9 GCR_SITE = http://ftp.acc.umu.se/pub/gnome/sources/gcr/$(GCR_VERSION_MAJOR)
10 GCR_SOURCE = gcr-$(GCR_VERSION).tar.xz
11 GCR_DEPENDENCIES = host-intltool host-pkgconf libgcrypt libglib2 p11-kit
12 GCR_INSTALL_STAGING = YES
13 GCR_CONF_ENV = ac_cv_path_GNUPG=/usr/bin/gpg2
14 GCR_CONF_OPTS = \
15 --disable-gtk-doc \
16 --with-libgcrypt-prefix=$(STAGING_DIR)/usr
17 # Even though COPYING is v2 the code states v2.1+
18 GCR_LICENSE = LGPLv2.1+
19 GCR_LICENSE_FILES = COPYING
21 # Only the X11 backend is supported for the simple GUI
22 ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
23 GCR_DEPENDENCIES += libgtk3
24 GCR_CONF_OPTS += --with-gtk
25 else
26 GCR_CONF_OPTS += --without-gtk
27 endif
29 $(eval $(autotools-package))