package/opencv: fix build failure on x86
[buildroot-gz.git] / package / gtest / gtest.mk
blob6a953504371ff66c77b282c5ca156d672d4c712e
1 ################################################################################
3 # gtest
5 ################################################################################
7 GTEST_VERSION = 1.7.0
8 GTEST_SOURCE = gtest-$(GTEST_VERSION).zip
9 GTEST_SITE = http://googletest.googlecode.com/files
10 GTEST_INSTALL_STAGING = YES
11 GTEST_INSTALL_TARGET = NO
12 GTEST_LICENSE = BSD-3c
13 GTEST_LICENSE_FILES = LICENSE
15 # While it is possible to build gtest as shared library, using this gtest shared
16 # library requires to set some special configure option in the project using
17 # gtest.
18 # So, force to build gtest as a static library.
20 # For further details, refer to the explaination given in the README file from
21 # the gtest sources.
22 GTEST_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF
24 define GTEST_EXTRACT_CMDS
25 unzip $(DL_DIR)/$(GTEST_SOURCE) -d $(BUILD_DIR)
26 endef
28 define GTEST_INSTALL_STAGING_CMDS
29 $(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
30 $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
31 cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
32 endef
34 $(eval $(cmake-package))