netsnmp: handle libnl dependency properly
[buildroot-gz.git] / package / libupnpp / libupnpp.mk
blob0cb3eae2ca7bd5de6dc64103d1768edf269fe939
1 ################################################################################
3 # libupnpp
5 ################################################################################
7 LIBUPNPP_VERSION = 0.15.1
8 LIBUPNPP_SITE = http://www.lesbonscomptes.com/upmpdcli/downloads
9 LIBUPNPP_LICENSE = GPLv2+
10 LIBUPNPP_LICENSE_FILES = COPYING
11 LIBUPNPP_INSTALL_STAGING = YES
12 LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
14 # configure script fails to link against the dependencies of libupnp
15 # and libcurl causing detection to fail when statically linking
16 ifeq ($(BR2_STATIC_LIBS),y)
17 LIBUPNPP_DEPENDENCIES += host-pkgconf
18 LIBUPNPP_CONF_ENV += \
19 LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libupnp libcurl`"
20 endif
22 $(eval $(autotools-package))