1 ################################################################################
5 ################################################################################
7 ERLANG_REBAR_VERSION
= 2.6.4
9 # Upstream publishes a release, but we can not use it as it is a release of
10 # a generated rebar script, when we want the sources. So we have to use the
11 # gihub helper in this case.
12 ERLANG_REBAR_SITE
= $(call github
,rebar
,rebar
,$(ERLANG_REBAR_VERSION
))
14 # Although the file LICENSE state Apache-2.0, a lot (if not all) the files
15 # in src/ bear the MIT licence.
16 ERLANG_REBAR_LICENSE
= Apache-2.0
, MIT
17 ERLANG_REBAR_LICENSE_FILES
= LICENSE
19 # We do not have a target variant, so just define the dependencies,
20 # configure and build commands for the host variant.
21 HOST_ERLANG_REBAR_DEPENDENCIES
= host-erlang
23 define HOST_ERLANG_REBAR_BUILD_CMDS
24 cd
$(@D
) && $(HOST_MAKE_ENV
) $(MAKE
)
27 define HOST_ERLANG_REBAR_INSTALL_CMDS
28 $(INSTALL
) -m
0755 -D
$(@D
)/rebar
$(HOST_DIR
)/usr
/bin
/rebar
31 $(eval
$(host-generic-package
))