1 ################################################################################
5 ################################################################################
7 LIBPLAYER_VERSION
= 2.0.1
8 LIBPLAYER_SITE
= http
://libplayer.geexbox.org
/releases
9 LIBPLAYER_SOURCE
= libplayer-
$(LIBPLAYER_VERSION
).
tar.bz2
10 LIBPLAYER_LICENSE
= LGPLv2.1
+
11 LIBPLAYER_LICENSE_FILES
= COPYING
13 # When passing the standard buildroot configure arguments, the configure script
14 # breaks on --target and --host options. Thus we need to define a configure cmd
16 define LIBPLAYER_CONFIGURE_CMDS
17 (cd
$(@D
) && rm -rf config.cache
&& \
18 $(TARGET_CONFIGURE_OPTS
) \
19 $(TARGET_CONFIGURE_ARGS
) \
23 $(SHARED_STATIC_LIBS_OPTS
) \
24 $(LIBPLAYER_CONF_OPTS
) \
28 ifeq ($(BR2_PACKAGE_LIBPLAYER_MPLAYER
),y
)
29 LIBPLAYER_DEPENDENCIES
+= mplayer
30 LIBPLAYER_CONF_OPTS
+= --enable-mplayer
32 LIBPLAYER_CONF_OPTS
+= --disable-mplayer
35 ifeq ($(BR2_PACKAGE_LIBPLAYER_GSTREAMER
),y
)
36 LIBPLAYER_DEPENDENCIES
+= gstreamer
37 LIBPLAYER_CONF_OPTS
+= --enable-gstreamer
39 LIBPLAYER_CONF_OPTS
+= --disable-gstreamer
42 ifeq ($(BR2_PACKAGE_LIBPLAYER_PYTHON
),y
)
43 LIBPLAYER_DEPENDENCIES
+= python
44 LIBPLAYER_CONF_OPTS
+= --enable-binding-python
47 $(eval
$(autotools-package
))