dbus: bump to version 1.10.14
[buildroot-gz.git] / package / jq / jq.mk
blob9a094ba9a0b87875b320ce262a6ca9f67a80d5f1
1 ################################################################################
3 # jq
5 ################################################################################
7 JQ_VERSION = 1.5
8 JQ_SITE = https://github.com/stedolan/jq/releases/download/jq-$(JQ_VERSION)
9 JQ_LICENSE = MIT (code), CC-BY-3.0 (documentation)
10 JQ_LICENSE_FILES = COPYING
12 # uses c99 specific features
13 JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
14 HOST_JQ_CONF_ENV += CFLAGS="$(HOST_CFLAGS) -std=c99"
16 # jq explicitly enables maintainer mode, which we don't need/want
17 JQ_CONF_OPTS += --disable-maintainer-mode
18 HOST_JQ_CONF_OPTS += --disable-maintainer-mode
20 $(eval $(autotools-package))
21 $(eval $(host-autotools-package))