1 ################################################################################
5 ################################################################################
8 JQ_SITE
= https
://github.com
/stedolan
/jq
/releases
/download
/jq-
$(JQ_VERSION
)
9 JQ_LICENSE
= MIT
(code
), CC-BY-3.0
(documentation
)
10 JQ_LICENSE_FILES
= COPYING
12 # uses c99 specific features
13 JQ_CONF_ENV
+= CFLAGS
="$(TARGET_CFLAGS) -std=c99"
14 HOST_JQ_CONF_ENV
+= CFLAGS
="$(HOST_CFLAGS) -std=c99"
16 # jq explicitly enables maintainer mode, which we don't need/want
17 JQ_CONF_OPTS
+= --disable-maintainer-mode
18 HOST_JQ_CONF_OPTS
+= --disable-maintainer-mode
20 $(eval
$(autotools-package
))
21 $(eval
$(host-autotools-package
))