configs: mx53loco: Bump U-Boot version to 2016.07
[buildroot-gz.git] / package / atftp / atftp.mk
blob615b6eadbbeecdd4d611b64d7033f3436b90a6c6
1 ################################################################################
3 # atftp
5 ################################################################################
7 ATFTP_VERSION = 0.7.1
8 ATFTP_SITE = http://sourceforge.net/projects/atftp/files
9 ATFTP_LICENSE = GPLv2+
10 ATFTP_LICENSE_FILES = LICENSE
11 ATFTP_CONF_OPTS = --disable-libwrap --disable-mtftp
12 # For static we need to explicitly link against libpthread
13 ATFTP_LIBS = -lpthread
14 # We use CPPFLAGS for -fgnu89-inline even though it's a compiler flag
15 # because atftp discards configure environment CFLAGS. -fgnu89-inline
16 # is needed to avoid multiple definition error with gcc 5. See
17 # https://gcc.gnu.org/gcc-5/porting_to.html.
18 ATFTP_CONF_ENV = LIBS="$(ATFTP_LIBS)" \
19 CPPFLAGS="$(TARGET_CPPFLAGS) -fgnu89-inline"
21 ifeq ($(BR2_PACKAGE_READLINE),y)
22 ATFTP_DEPENDENCIES += readline
23 ATFTP_CONF_OPTS += --enable-libreadline
24 # For static, readline links with ncurses
25 ATFTP_LIBS += -lncurses
26 else
27 ATFTP_CONF_OPTS += --disable-libreadline
28 endif
30 ifeq ($(BR2_PACKAGE_PCRE),y)
31 ATFTP_DEPENDENCIES += pcre
32 ATFTP_CONF_OPTS += --enable-libpcre
33 else
34 ATFTP_CONF_OPTS += --disable-libpcre
35 endif
37 $(eval $(autotools-package))