1 ################################################################################
5 ################################################################################
8 ATFTP_SITE
= http
://sourceforge.net
/projects
/atftp
/files
10 ATFTP_LICENSE_FILES
= LICENSE
11 ATFTP_CONF_OPTS
= --disable-libwrap
--disable-mtftp
12 # For static we need to explicitly link against libpthread
13 ATFTP_LIBS
= -lpthread
14 # We use CPPFLAGS for -fgnu89-inline even though it's a compiler flag
15 # because atftp discards configure environment CFLAGS. -fgnu89-inline
16 # is needed to avoid multiple definition error with gcc 5. See
17 # https://gcc.gnu.org/gcc-5/porting_to.html.
18 ATFTP_CONF_ENV
= LIBS
="$(ATFTP_LIBS)" \
19 CPPFLAGS
="$(TARGET_CPPFLAGS) -fgnu89-inline"
21 ifeq ($(BR2_PACKAGE_READLINE
),y
)
22 ATFTP_DEPENDENCIES
+= readline
23 ATFTP_CONF_OPTS
+= --enable-libreadline
24 # For static, readline links with ncurses
25 ATFTP_LIBS
+= -lncurses
27 ATFTP_CONF_OPTS
+= --disable-libreadline
30 ifeq ($(BR2_PACKAGE_PCRE
),y
)
31 ATFTP_DEPENDENCIES
+= pcre
32 ATFTP_CONF_OPTS
+= --enable-libpcre
34 ATFTP_CONF_OPTS
+= --disable-libpcre
37 $(eval
$(autotools-package
))