configs: mx53loco: Bump U-Boot version to 2016.07
[buildroot-gz.git] / package / grep / grep.mk
blobf87e83829917755f4fd7a3272595ad32d30d5b9b
1 ################################################################################
3 # grep
5 ################################################################################
7 GREP_VERSION = 2.25
8 GREP_SITE = $(BR2_GNU_MIRROR)/grep
9 GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
10 GREP_LICENSE = GPLv3+
11 GREP_LICENSE_FILES = COPYING
12 GREP_CONF_OPTS = --disable-perl-regexp \
13 $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
14 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
16 # link with iconv if enabled
17 ifeq ($(BR2_PACKAGE_LIBICONV),y)
18 GREP_CONF_ENV += LIBS=-liconv
19 GREP_DEPENDENCIES += libiconv
20 endif
22 # link with pcre if enabled
23 ifeq ($(BR2_PACKAGE_PCRE),y)
24 GREP_CONF_OPTS += --enable-perl-regexp
25 GREP_DEPENDENCIES += pcre
26 endif
28 # Full grep preferred over busybox grep
29 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
30 GREP_DEPENDENCIES += busybox
31 endif
33 $(eval $(autotools-package))