1 ################################################################################
5 ################################################################################
8 GREP_SITE
= $(BR2_GNU_MIRROR
)/grep
9 GREP_SOURCE
= grep-
$(GREP_VERSION
).
tar.xz
11 GREP_LICENSE_FILES
= COPYING
12 GREP_CONF_OPTS
= --disable-perl-regexp \
13 $(if
$(BR2_TOOLCHAIN_USES_MUSL
),--with-included-regex
)
14 GREP_DEPENDENCIES
= $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext
)
16 # link with iconv if enabled
17 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
18 GREP_CONF_ENV
+= LIBS
=-liconv
19 GREP_DEPENDENCIES
+= libiconv
22 # link with pcre if enabled
23 ifeq ($(BR2_PACKAGE_PCRE
),y
)
24 GREP_CONF_OPTS
+= --enable-perl-regexp
25 GREP_DEPENDENCIES
+= pcre
28 # Full grep preferred over busybox grep
29 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
30 GREP_DEPENDENCIES
+= busybox
33 $(eval
$(autotools-package
))