git: fix build with with no threads
[buildroot-gz.git] / package / openzwave / openzwave.mk
blob199d9e1bd011bbcc89ded0d4614c4e4982d94df1
1 ################################################################################
3 # openzwave
5 ################################################################################
7 OPENZWAVE_VERSION = V1.5
8 OPENZWAVE_SITE = $(call github,OpenZWave,open-zwave,$(OPENZWAVE_VERSION))
9 OPENZWAVE_LICENSE = LGPLv3+, GPLv3 (examples), Apache-2.0 (sh2ju.sh)
10 OPENZWAVE_LICENSE_FILES = license/license.txt license/lgpl.txt \
11 license/gpl.txt license/Apache-License-2.0.txt
13 OPENZWAVE_DEPENDENCIES = host-pkgconf udev
14 OPENZWAVE_INSTALL_STAGING = YES
16 # This patch fixes incorrect default value of LIBDIR:
17 # http://autobuild.buildroot.net/results/68719fdf1320a69310bada6d3c47654dacdb5898
18 # This patch is currently in dev branch and will be a part of v1.6
19 OPENZWAVE_PATCH = \
20 https://github.com/OpenZWave/open-zwave/commit/599e2a11c6f48dde744012ec45686c08e15f3059.patch
22 # Set instlibdir to install libopenzwave.so* in the correct directory
23 # otherwise openzwave will check that /lib64 exists (on the host) to
24 # know if the library should be installed in $(PREFIX)/lib or $(PREFIX)/lib64.
25 # Set pkgconfigdir to /lib/pkgconfig to install libopenzwave.pc in the
26 # correct directory otherwise openzwave will call
27 # "pkg-config --variable pc_path pkg-config" which returns an incorrect value.
28 # Set sysconfdir to /etc/openzwave to install openzwave configuration files in
29 # the correct directory otherwise openzwave will install configuration files in
30 # $(PREFIX)/etc/openzwave.
31 # Disable doxygen documentation.
32 OPENZWAVE_MAKE_OPTS = \
33 CROSS_COMPILE="$(TARGET_CROSS)" \
34 PREFIX=/usr \
35 instlibdir=/usr/lib \
36 pkgconfigdir=/usr/lib/pkgconfig \
37 sysconfdir=/etc/openzwave \
38 DOXYGEN=
40 define OPENZWAVE_BUILD_CMDS
41 $(TARGET_MAKE_ENV) $(MAKE) $(OPENZWAVE_MAKE_OPTS) -C $(@D)
42 endef
44 define OPENZWAVE_INSTALL_STAGING_CMDS
45 $(TARGET_MAKE_ENV) $(MAKE) $(OPENZWAVE_MAKE_OPTS) -C $(@D) \
46 DESTDIR=$(STAGING_DIR) install
47 endef
49 # Delete unneeded ozw_config binary from target directory as this is an utility
50 # application used to get the openzwave build configuration.
51 define OPENZWAVE_INSTALL_TARGET_CMDS
52 $(TARGET_MAKE_ENV) $(MAKE) $(OPENZWAVE_MAKE_OPTS) -C $(@D) \
53 DESTDIR=$(TARGET_DIR) install
54 rm -f $(TARGET_DIR)/usr/bin/ozw_config
55 endef
57 $(eval $(generic-package))