git: fix build with with no threads
[buildroot-gz.git] / package / supertuxkart / supertuxkart.mk
blob037c6f359dc1c7eb942f02752ec0a182e4f0b75c
1 ################################################################################
3 # supertuxkart
5 ################################################################################
7 SUPERTUXKART_VERSION = 0.9.2
8 SUPERTUXKART_SOURCE = supertuxkart-$(SUPERTUXKART_VERSION)-src.tar.xz
9 SUPERTUXKART_SITE = http://downloads.sourceforge.net/project/supertuxkart/SuperTuxKart/$(SUPERTUXKART_VERSION)
11 # Supertuxkart itself is GPLv3+, but it bundles a few libraries with different
12 # licenses. Irrlicht, bullet and angelscript have zlib license, while glew is
13 # BSD-3c. Since they are linked statically, the result is GPLv3+.
14 SUPERTUXKART_LICENSE = GPLv3+
15 SUPERTUXKART_LICENSE_FILES = COPYING
17 SUPERTUXKART_DEPENDENCIES = \
18 jpeg \
19 libcurl \
20 libgl \
21 libglu \
22 libogg \
23 libpng \
24 libvorbis \
25 openal \
26 xlib_libXrandr \
27 zlib
29 # Since supertuxkart is not installing libstkirrlicht.so, and since it is
30 # the only user of the bundled libraries, turn off shared libraries entirely.
31 SUPERTUXKART_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF
33 ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
34 SUPERTUXKART_DEPENDENCIES += libfribidi
35 SUPERTUXKART_CONF_OPTS += -DUSE_FRIBIDI=ON
36 else
37 SUPERTUXKART_CONF_OPTS += -DUSE_FRIBIDI=OFF
38 endif
40 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
41 SUPERTUXKART_DEPENDENCIES += bluez5_utils
42 SUPERTUXKART_CONF_OPTS += -DUSE_WIIUSE=ON
43 else
44 # Wiimote support relies on bluez5.
45 SUPERTUXKART_CONF_OPTS += -DUSE_WIIUSE=OFF
46 endif
48 $(eval $(cmake-package))