1 ################################################################################
5 ################################################################################
7 PHP_GNUPG_VERSION
= 30fab6eaf9eb61c65b3b46987442be058cbd7823
8 PHP_GNUPG_SITE
= $(call github
,Sean-Der
,pecl-encryption-gnupg
,$(PHP_GNUPG_VERSION
))
9 # phpize does the autoconf magic
10 PHP_GNUPG_DEPENDENCIES
= php libgpgme host-autoconf host-pkgconf
11 PHP_GNUPG_CONF_OPTS
= --with-php-config
=$(STAGING_DIR
)/usr
/bin
/php-config \
12 --with-gnupg
=$(STAGING_DIR
)/usr
/include --with-gpg
=/usr
/bin
/gpg
13 PHP_GNUPG_LICENSE
= BSD-2c
14 PHP_GNUPG_LICENSE_FILES
= LICENSE
16 define PHP_GNUPG_PHPIZE
18 PHP_AUTOCONF
=$(HOST_DIR
)/usr
/bin
/autoconf \
19 PHP_AUTOHEADER
=$(HOST_DIR
)/usr
/bin
/autoheader \
20 $(STAGING_DIR
)/usr
/bin
/phpize
)
23 PHP_GNUPG_PRE_CONFIGURE_HOOKS
+= PHP_GNUPG_PHPIZE
25 $(eval
$(autotools-package
))