1 ################################################################################
5 ################################################################################
7 PYTHON_VERSION_MAJOR
= 2.7
8 PYTHON_VERSION
= $(PYTHON_VERSION_MAJOR
).13
9 PYTHON_SOURCE
= Python-
$(PYTHON_VERSION
).
tar.xz
10 PYTHON_SITE
= http
://python.org
/ftp
/python
/$(PYTHON_VERSION
)
11 PYTHON_LICENSE
= Python software foundation license v2
, others
12 PYTHON_LICENSE_FILES
= LICENSE
13 PYTHON_LIBTOOL_PATCH
= NO
15 # Python needs itself to be built, so in order to cross-compile
16 # Python, we need to build a host Python first. This host Python is
17 # also installed in $(HOST_DIR), as it is needed when cross-compiling
18 # third-party Python modules.
20 HOST_PYTHON_CONF_OPTS
+= \
27 --disable-codecs-cjk \
29 --enable-unicodedata \
33 --disable-test-modules \
36 --disable-ossaudiodev \
39 # Make sure that LD_LIBRARY_PATH overrides -rpath.
40 # This is needed because libpython may be installed at the same time that
42 # Make python believe we don't have 'hg' and 'svn', so that it doesn't
43 # try to communicate over the network during the build.
44 HOST_PYTHON_CONF_ENV
+= \
45 LDFLAGS
="$(HOST_LDFLAGS) -Wl,--enable-new-dtags" \
46 ac_cv_prog_HAS_HG
=/bin
/false \
47 ac_cv_prog_SVNVERSION
=/bin
/false
49 # Building host python in parallel sometimes triggers a "Bus error"
50 # during the execution of "./python setup.py build" in the
51 # installation step. It is probably due to the installation of a
52 # shared library taking place in parallel to the execution of
53 # ./python, causing spurious Bus error. Building host-python with
54 # MAKE1 has shown to workaround the problem.
55 HOST_PYTHON_MAKE
= $(MAKE1
)
57 PYTHON_DEPENDENCIES
= host-python libffi
59 HOST_PYTHON_DEPENDENCIES
= host-expat host-zlib
61 PYTHON_INSTALL_STAGING
= YES
63 ifeq ($(BR2_PACKAGE_PYTHON_READLINE
),y
)
64 PYTHON_DEPENDENCIES
+= readline
67 ifeq ($(BR2_PACKAGE_PYTHON_CURSES
),y
)
68 PYTHON_DEPENDENCIES
+= ncurses
70 PYTHON_CONF_OPTS
+= --disable-curses
73 ifeq ($(BR2_PACKAGE_PYTHON_PYEXPAT
),y
)
74 PYTHON_DEPENDENCIES
+= expat
75 PYTHON_CONF_OPTS
+= --with-expat
=system
77 PYTHON_CONF_OPTS
+= --with-expat
=none
80 ifeq ($(BR2_PACKAGE_PYTHON_BSDDB
),y
)
81 PYTHON_DEPENDENCIES
+= berkeleydb
83 PYTHON_CONF_OPTS
+= --disable-bsddb
86 ifeq ($(BR2_PACKAGE_PYTHON_SQLITE
),y
)
87 PYTHON_DEPENDENCIES
+= sqlite
89 PYTHON_CONF_OPTS
+= --disable-sqlite3
92 ifeq ($(BR2_PACKAGE_PYTHON_SSL
),y
)
93 PYTHON_DEPENDENCIES
+= openssl
95 PYTHON_CONF_OPTS
+= --disable-ssl
98 ifneq ($(BR2_PACKAGE_PYTHON_CODECSCJK
),y
)
99 PYTHON_CONF_OPTS
+= --disable-codecs-cjk
102 ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA
),y
)
103 PYTHON_CONF_OPTS
+= --disable-unicodedata
106 # Default is UCS2 w/o a conf opt
107 ifeq ($(BR2_PACKAGE_PYTHON_UCS4
),y
)
108 # host-python must have the same UCS2/4 configuration as the target
110 HOST_PYTHON_CONF_OPTS
+= --enable-unicode
=ucs4
111 PYTHON_CONF_OPTS
+= --enable-unicode
=ucs4
114 ifeq ($(BR2_PACKAGE_PYTHON_BZIP2
),y
)
115 PYTHON_DEPENDENCIES
+= bzip2
117 PYTHON_CONF_OPTS
+= --disable-bz2
120 ifeq ($(BR2_PACKAGE_PYTHON_ZLIB
),y
)
121 PYTHON_DEPENDENCIES
+= zlib
123 PYTHON_CONF_OPTS
+= --disable-zlib
126 ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB
),y
)
127 PYTHON_DEPENDENCIES
+= openssl
130 ifeq ($(BR2_PACKAGE_PYTHON_OSSAUDIODEV
),y
)
131 PYTHON_CONF_OPTS
+= --enable-ossaudiodev
133 PYTHON_CONF_OPTS
+= --disable-ossaudiodev
136 # Make python believe we don't have 'hg' and 'svn', so that it doesn't
137 # try to communicate over the network during the build.
139 ac_cv_have_long_long_format
=yes \
140 ac_cv_file__dev_ptmx
=yes \
141 ac_cv_file__dev_ptc
=yes \
142 ac_cv_working_tzset
=yes \
143 ac_cv_prog_HAS_HG
=/bin
/false \
144 ac_cv_prog_SVNVERSION
=/bin
/false
146 # GCC is always compliant with IEEE754
147 ifeq ($(BR2_ENDIAN
),"LITTLE")
148 PYTHON_CONF_ENV
+= ac_cv_little_endian_double
=yes
150 PYTHON_CONF_ENV
+= ac_cv_big_endian_double
=yes
153 PYTHON_CONF_OPTS
+= \
155 --without-doc-strings \
158 --disable-test-modules \
164 --disable-pyo-build \
167 # This is needed to make sure the Python build process doesn't try to
168 # regenerate those files with the pgen program. Otherwise, it builds
169 # pgen for the target, and tries to run it on the host.
171 define PYTHON_TOUCH_GRAMMAR_FILES
172 touch
$(@D
)/Include
/graminit.h
$(@D
)/Python
/graminit.c
175 PYTHON_POST_PATCH_HOOKS
+= PYTHON_TOUCH_GRAMMAR_FILES
178 # Remove useless files. In the config/ directory, only the Makefile
179 # and the pyconfig.h files are needed at runtime.
181 # idle & smtpd.py have bad shebangs and are mostly samples
183 define PYTHON_REMOVE_USELESS_FILES
184 rm -f
$(TARGET_DIR
)/usr
/bin
/python
$(PYTHON_VERSION_MAJOR
)-config
185 rm -f
$(TARGET_DIR
)/usr
/bin
/python2-config
186 rm -f
$(TARGET_DIR
)/usr
/bin
/python-config
187 rm -f
$(TARGET_DIR
)/usr
/bin
/smtpd.py
188 for i in
`find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config/ \
189 -type f -not -name pyconfig.h -a -not -name Makefile` ; do \
194 PYTHON_POST_INSTALL_TARGET_HOOKS
+= PYTHON_REMOVE_USELESS_FILES
197 # Make sure libpython gets stripped out on target
199 define PYTHON_ENSURE_LIBPYTHON_STRIPPED
200 chmod u
+w
$(TARGET_DIR
)/usr
/lib
/libpython
$(PYTHON_VERSION_MAJOR
)*.so
203 PYTHON_POST_INSTALL_TARGET_HOOKS
+= PYTHON_ENSURE_LIBPYTHON_STRIPPED
205 # Always install the python symlink in the target tree
206 define PYTHON_INSTALL_TARGET_PYTHON_SYMLINK
207 ln
-sf python2
$(TARGET_DIR
)/usr
/bin
/python
210 PYTHON_POST_INSTALL_TARGET_HOOKS
+= PYTHON_INSTALL_TARGET_PYTHON_SYMLINK
212 # Always install the python-config symlink in the staging tree
213 define PYTHON_INSTALL_STAGING_PYTHON_CONFIG_SYMLINK
214 ln
-sf python2-config
$(STAGING_DIR
)/usr
/bin
/python-config
217 PYTHON_POST_INSTALL_STAGING_HOOKS
+= PYTHON_INSTALL_STAGING_PYTHON_CONFIG_SYMLINK
219 PYTHON_AUTORECONF
= YES
221 # Some packages may have build scripts requiring python2.
222 # Only install the python symlink in the host tree if python3 is not enabled
223 # for the target, otherwise the default python program may be missing.
224 ifneq ($(BR2_PACKAGE_PYTHON3
),y
)
225 define HOST_PYTHON_INSTALL_PYTHON_SYMLINK
226 ln
-sf python2
$(HOST_DIR
)/usr
/bin
/python
227 ln
-sf python2-config
$(HOST_DIR
)/usr
/bin
/python-config
230 HOST_PYTHON_POST_INSTALL_HOOKS
+= HOST_PYTHON_INSTALL_PYTHON_SYMLINK
233 # Provided to other packages
234 PYTHON_PATH
= $(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/sysconfigdata
/:$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
/
236 $(eval
$(autotools-package
))
237 $(eval
$(host-autotools-package
))
239 define PYTHON_CREATE_PYC_FILES
240 PYTHONPATH
="$(PYTHON_PATH)" \
241 $(HOST_DIR
)/usr
/bin
/python
$(PYTHON_VERSION_MAJOR
) \
242 support
/scripts
/pycompile.py \
243 $(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)
246 ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY
)$(BR2_PACKAGE_PYTHON_PY_PYC
),y
)
247 PYTHON_TARGET_FINALIZE_HOOKS
+= PYTHON_CREATE_PYC_FILES
250 ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY
),y
)
251 define PYTHON_REMOVE_PY_FILES
252 find
$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
) -name
'*.py' -print0 | \
253 xargs
-0 --no-run-if-empty
rm -f
255 PYTHON_TARGET_FINALIZE_HOOKS
+= PYTHON_REMOVE_PY_FILES
258 # Normally, *.pyc files should not have been compiled, but just in
259 # case, we make sure we remove all of them.
260 ifeq ($(BR2_PACKAGE_PYTHON_PY_ONLY
),y
)
261 define PYTHON_REMOVE_PYC_FILES
262 find
$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
) -name
'*.pyc' -print0 | \
263 xargs
-0 --no-run-if-empty
rm -f
265 PYTHON_TARGET_FINALIZE_HOOKS
+= PYTHON_REMOVE_PYC_FILES
268 # In all cases, we don't want to keep the optimized .pyo files
269 define PYTHON_REMOVE_PYO_FILES
270 find
$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
) -name
'*.pyo' -print0 | \
271 xargs
-0 --no-run-if-empty
rm -f
273 PYTHON_TARGET_FINALIZE_HOOKS
+= PYTHON_REMOVE_PYO_FILES