1 ################################################################################
5 ################################################################################
7 PHP_GEOIP_VERSION
= ebb68228ad94298a305710f701b2ade9acff985d
8 PHP_GEOIP_SITE
= $(call github
,php7-extensions
,ext-php7-geoip
,$(PHP_GEOIP_VERSION
))
9 PHP_GEOIP_CONF_OPTS
= --with-php-config
=$(STAGING_DIR
)/usr
/bin
/php-config \
10 --with-geoip
=$(STAGING_DIR
)/usr
11 # phpize does the autoconf magic
12 PHP_GEOIP_DEPENDENCIES
= geoip php host-autoconf
13 PHP_GEOIP_LICENSE
= PHP
14 PHP_GEOIP_LICENSE_FILES
= geoip.c
16 define PHP_GEOIP_PHPIZE
18 PHP_AUTOCONF
=$(HOST_DIR
)/usr
/bin
/autoconf \
19 PHP_AUTOHEADER
=$(HOST_DIR
)/usr
/bin
/autoheader \
20 $(STAGING_DIR
)/usr
/bin
/phpize
)
23 PHP_GEOIP_PRE_CONFIGURE_HOOKS
+= PHP_GEOIP_PHPIZE
25 $(eval
$(autotools-package
))