lua-csnappy: bump to version 0.1.4
[buildroot-gz.git] / package / libsvgtiny / libsvgtiny.mk
blobacd08d72d598588c128258b82d75216ca5946ce8
1 ################################################################################
3 # libsvgtiny
5 ################################################################################
7 LIBSVGTINY_SITE = http://git.netsurf-browser.org/libsvgtiny.git
8 LIBSVGTINY_SITE_METHOD = git
9 LIBSVGTINY_VERSION = ea9d99fc8b231c22d06168135e181d61f4eb2f06
10 LIBSVGTINY_INSTALL_STAGING = YES
11 LIBSVGTINY_DEPENDENCIES = \
12 libxml2 host-gperf host-pkgconf host-netsurf-buildsystem
13 LIBSVGTINY_LICENSE = MIT
14 LIBSVGTINY_LICENSE_FILES = README
16 # The libsvgtiny build system cannot build both the shared and static
17 # libraries. So when the Buildroot configuration requests to build
18 # both the shared and static variants, we build only the shared one.
19 ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
20 LIBSVGTINY_COMPONENT_TYPE = lib-shared
21 else
22 LIBSVGTINY_COMPONENT_TYPE = lib-static
23 endif
25 define LIBSVGTINY_CONFIGURE_CMDS
26 ln -sf $(HOST_DIR)/usr/share/netsurf-buildsystem $(@D)/build
27 endef
29 define LIBSVGTINY_BUILD_CMDS
30 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr \
31 COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE)
32 endef
34 define LIBSVGTINY_INSTALL_STAGING_CMDS
35 $(TARGET_CONFIGURE_OPTS) \
36 $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) \
37 COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
38 endef
40 define LIBSVGTINY_INSTALL_TARGET_CMDS
41 $(TARGET_CONFIGURE_OPTS) \
42 $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) \
43 COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
44 endef
46 $(eval $(generic-package))