gst1-plugins-base: bump to version 1.10.4
[buildroot-gz.git] / package / cryptsetup / cryptsetup.mk
blob50bf5f2aaf02573e16dde53dd30abbb3d20d689d
1 ################################################################################
3 # cryptsetup
5 ################################################################################
7 CRYPTSETUP_VERSION_MAJOR = 1.7
8 CRYPTSETUP_VERSION = $(CRYPTSETUP_VERSION_MAJOR).3
9 CRYPTSETUP_SOURCE = cryptsetup-$(CRYPTSETUP_VERSION).tar.xz
10 CRYPTSETUP_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/cryptsetup/v$(CRYPTSETUP_VERSION_MAJOR)
11 CRYPTSETUP_DEPENDENCIES = lvm2 popt util-linux host-pkgconf \
12 $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
13 CRYPTSETUP_LICENSE = GPLv2+ (programs), LGPLv2.1+ (library)
14 CRYPTSETUP_LICENSE_FILES = COPYING COPYING.LGPL
16 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
17 CRYPTSETUP_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -lintl"
18 endif
20 # cryptsetup uses libgcrypt by default, but can be configured to use OpenSSL
21 # or kernel crypto modules instead
22 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
23 CRYPTSETUP_DEPENDENCIES += libgcrypt
24 CRYPTSETUP_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
25 CRYPTSETUP_CONF_OPTS += --with-crypto_backend=gcrypt
26 else ifeq ($(BR2_PACKAGE_OPENSSL),y)
27 CRYPTSETUP_DEPENDENCIES += openssl
28 CRYPTSETUP_CONF_OPTS += --with-crypto_backend=openssl
29 else
30 CRYPTSETUP_CONF_OPTS += --with-crypto_backend=kernel
31 endif
33 $(eval $(autotools-package))