gst1-plugins-base: bump to version 1.10.4
[buildroot-gz.git] / package / tremor / tremor.mk
blob2a791b6729f15065f6ac307bf5bff5be5ee31b75
1 ################################################################################
3 # tremor
5 ################################################################################
7 TREMOR_SITE = http://svn.xiph.org/trunk/Tremor
8 TREMOR_SITE_METHOD = svn
9 TREMOR_VERSION = 19427
10 TREMOR_LICENSE = BSD-3c
11 TREMOR_LICENSE_FILES = COPYING
13 TREMOR_AUTORECONF = YES
14 TREMOR_INSTALL_STAGING = YES
15 TREMOR_DEPENDENCIES = libogg
17 # tremor has ARM assembly code that cannot be compiled in Thumb2 mode,
18 # so we must force the traditional ARM mode.
19 # However, some ARM architectures like ARNv7-M only supports Thumb
20 # instructions, but the tremor build configuration enables ARM assembly
21 # code unconditionally for all arm triplets by defining _ARM_ASSEM_.
22 # We are overriding this by undefining this macro for the ARM
23 # architectures not supporting ARM instructions.
24 ifeq ($(BR2_arm),y)
25 ifeq ($(BR2_ARM_CPU_HAS_ARM),y)
26 TREMOR_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
27 else
28 TREMOR_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -U_ARM_ASSEM_"
29 endif
30 endif
32 $(eval $(autotools-package))