micropython: Set MICROPY_GCREGS_SETJMP=1 for xtensa and sh
[buildroot-gz.git] / package / libtool / libtool.mk
blob8688f8b20cc42f0ff8dd881229c89d491497793e
1 ################################################################################
3 # libtool
5 ################################################################################
7 LIBTOOL_VERSION = 2.4.6
8 LIBTOOL_SOURCE = libtool-$(LIBTOOL_VERSION).tar.xz
9 LIBTOOL_SITE = $(BR2_GNU_MIRROR)/libtool
10 LIBTOOL_INSTALL_STAGING = YES
11 LIBTOOL_CONF_ENV = HELP2MAN=true
12 LIBTOOL_DEPENDENCIES = host-m4
13 LIBTOOL_LICENSE = GPLv2+
14 LIBTOOL_LICENSE_FILES = COPYING
16 HOST_LIBTOOL_CONF_ENV = MAKEINFO=true
17 HOST_LIBTOOL_LIBTOOL_PATCH = NO
19 # We have a patch that affects libtool.m4, which triggers an autoreconf
20 # in the build step. Normally we would set AUTORECONF = YES, but this
21 # doesn't work for host-libtool because that creates a circular
22 # dependency. Instead, touch the generated files so autoreconf is not
23 # triggered in the build step. Note that aclocal.m4 has to be touched
24 # first since the rest depends on it. Note that we don't need the changes
25 # in libtool.m4 in our configure script, because we're not actually
26 # running it on the target.
27 # For the target, we would normally be able to use AUTORECONF, but it
28 # fails on libltdl/Makefile.inc. Rather than trying to fix that failure,
29 # just use the same hack as on the host.
30 define LIBTOOL_AVOID_AUTORECONF_HOOK
31 find $(@D) -name aclocal.m4 -exec touch '{}' \;
32 find $(@D) -name config-h.in -exec touch '{}' \;
33 find $(@D) -name configure -exec touch '{}' \;
34 find $(@D) -name Makefile.in -exec touch '{}' \;
35 endef
36 LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
37 HOST_LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
39 $(eval $(autotools-package))
40 $(eval $(host-autotools-package))
42 # variables used by other packages
43 LIBTOOL = $(HOST_DIR)/usr/bin/libtool
44 LIBTOOLIZE = $(HOST_DIR)/usr/bin/libtoolize